-   Linux - General (
-   -   Deleting a directory... (

closet geek 07-08-2003 04:04 PM

Deleting a directory...
ripperx (rips cd tracks) created what seemed like a bulletproof directory for an album I ripped, I decided I didn't want the directory which contained the album so went to delete it, but got permissioin denied...

I logged in as root to BASH then tried to use the rm command to remove it but everytime I confirmed I wanted to delete it, it would appear to do it, but the directory was still there :confused:

So I thought maybe I could change the permissions using chmod but that didn't get me anywhere I still couldn't delete it from a normal user account.

I had to log out :mad: and log back in as root to get rid of it :rolleyes:

Any ideas how I could've got ridden of it from a normal user account? Would right clicking it then changing the permissions from in there help, I don't see a delete option though, only able to make it writeable, executable & readable?!


p.s. apologies I haven't got the permissions is came with written down, it was in the root user group though.

Tinkster 07-08-2003 04:22 PM

What permissions/ownerships do the directories/files
get when ripperx writes them? Could you
post a
ls -l
of one of those?


closet geek 07-08-2003 04:33 PM

here it is...


total 4
-rw-r--r-- 1 root closetgeek 128 Jul 7 22:27 - track 1.mp3

andrewlkho 07-08-2003 04:39 PM

um...I know this sounds dumb, but did you use the correct syntax? Sometimes, if you just 'rm dir/', it'll do that, you have to 'rm -R dir/' to delete the directory itself. Sorry if I'm being patronising...

closet geek 07-08-2003 05:10 PM

ho_10 it's cool!! I'm the kinda person who'd do that...

the exact command I used to try and delete the directory was:

rm -R /home/closetgeek/Desktop/test

it then asked me if I was sure, I hit enter, it presented me with another command line so I assumed it was done, yet, the damn directory is still there :rolleyes:


andrewlkho 07-08-2003 07:53 PM

okay...two questions:
firstly, is this only one instance of this happening [ie have you ripped a cd and tried to delete the directory before?]
secondly, is the program you used to create the directory still running? you could try rebooting your computer - the directory may be 'busy'

gdrobson 07-08-2003 08:53 PM

I have had no problems logging in as root, and then typing :

rm -rf dirctory_to _delete .

the f option forces the delete, so you do not have to type 'y' to confirm it, and the r option makes it recursivly delete subdirectories as well.

closet geek 07-09-2003 06:25 AM

It turns out the f was what was needed, for some reason if I type y to confirm the deletion it wouldn't do it but

rm -rf <directory> worked :D

thanks all!


p.s. I just got samba working too! Next up giFT or KL through wine :p

All times are GMT -5. The time now is 05:24 AM.