Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 04-23-2006, 12:50 PM   #1
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
Unhappy Debugging and/or error messages appearing on VTs

Hello all,

I have a problem in that when I am using Virtual Terminals for day-to-day stuff, many messages come up. At one point, this was just occasionally when I plugged a USB device or whatever in, and was tolerable, but especially since I established a firewall, I keep getting many messages.

They vary in content, some are reporting errors, or new hardware detected, some are reporting the firewall activity.

They are all very disruptive, since they interfere with curses displays, and half the time I can't see what I'm typing.

Is it possible to disable them, limit them to 1 VT or send them to a log file instead?

I am running Debian Testing, Linux Kernel 2.6

Any help you can offer would be very much appreciated
Old 04-23-2006, 12:56 PM   #2
Registered: Apr 2006
Location: Pittsburgh
Distribution: Debian Sid AMD64
Posts: 296

Rep: Reputation: 30
You need to edit /etc/syslog.conf and get rid of the line that sends messages to '*'. Those same messages are going to a logfile already.
Old 04-23-2006, 05:40 PM   #3
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Original Poster
Rep: Reputation: 15
Thanks for the tip, at first it didn't seem to do anything, but it made me think, so I checked my iptables configs, and it was set for full logging, giving me details of every packet, so I changed the logging settings, and all is now fine and dandy!!

Thanks again for the help.
Old 06-14-2006, 12:03 PM   #4
Senior Member
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Thanks, ataraxia and fuzzyworm! Due to these posts from both of you, I fixed the same problem that I was having since newly installing Xubuntu Dapper. I just disabled logging using guarddog and so far no more messages.

If I want to see who's bombarding me, I can use ethereal. Those messages were absolutely useless and logging slowed down the system as well as making it sometimes impossible to enter commands in a virtual console.

You've just made one user's life easier.


debian, drop, firewall, iptables, logging, packet, tty, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
"INPUT Packet died" Messages Keep Appearing? Nickj Linux - Security 7 08-05-2005 08:48 AM
Linux Runs Vosa Vts Devices pengy666 General 1 05-18-2005 06:30 AM
From where am i getting error messages to /var/log/messages? prabhuacsp Programming 3 02-16-2005 08:59 AM
From where am i getting error messages to /var/log/messages? prabhuacsp Linux - Networking 1 02-16-2005 12:34 AM
Multiple "eth0: interrupt(s) dropped" messages appearing CaptainRandom Debian 1 05-16-2004 03:39 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:00 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration