LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-04-2004, 03:23 PM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 15.0 (multilib)
Posts: 1,356

Rep: Reputation: 76
Daytime Saving time. Cannot change time


Last weekend our clocks moved back an hour.

I was on my PC in linux at the time and I think the clock switched automatically.

Now, however it is showing an hour early.

I suspect that what has happened is that Windows has messed up the clock when it moved to GMT(I am running dual boot with Win 98SE)

Is there anything I can do about this.

Whenever I go into Control Centre Administrator mode to try and change the time the KDE control module crashes

Thanks.

Alan
 
Old 11-04-2004, 03:37 PM   #2
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
daylight savings time came, your PC did the 'fall-back' thing, and now your clock is an hour behind?

--is this a dual boot?
 
Old 11-04-2004, 04:41 PM   #3
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 15.0 (multilib)
Posts: 1,356

Original Poster
Rep: Reputation: 76
As I wrote. This is a dual boot and I was wondering if Windows 98 has put back the system clock so Linux (KDE) is now showing an hour early.
 
Old 11-04-2004, 05:06 PM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
You can use date from root right now it would be;
date 110418032004 which is 11/04 [today]1803 [my local time]2004[year]
 
Old 11-05-2004, 10:18 AM   #5
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
oops... sorry i just skimmed it-- you're problem is that both OSes are rolling back for daylight savings time.

you should fix this so that only one OS will adjust time for DST
 
Old 11-05-2004, 10:35 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,517

Rep: Reputation: 58
I have a similar problem on a dual boot. It seems that everything is fine as long as I run only one system. But if I switch between the systems (I just booted accidentally into Linux because Windows update wanted to reboot and Linux is my default system) the clock runs about 40 min late. In Windows, the automatic adjustment is switched off. On Linux however, xntpd is running. Could that be the problem?
 
Old 11-05-2004, 10:58 AM   #7
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
'it seem everything is fine as long as you run one OS'
--yup, that's the point. as soon as DST rolls around and it's time to update your clock, your OS will recognize that and change your clock. so if you're running happily along in linux, DST comes and goes, and you then need to boot to windows for some reason, when you do, you'll get your clock mucked.

'about 40 mins late'.. eh, you got me on that one... i'm sure xntp is playing a role, though
 
Old 11-06-2004, 11:30 AM   #8
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,517

Rep: Reputation: 58
I guess I found the solution (at least for my system): SuSE recommends to set the system clock to 'local time' instead of 'GMT' on dual boot systems, claiming that Windows uses the same setting. I now tried to use GMT instead and see, the clock runs correctly.

About those 40 min I am not that sure anymore Maybe the clock wasn't set correctly... sorry!
 
Old 11-06-2004, 02:06 PM   #9
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
yes, windows defaults to sys clock of localtime... when running dual boot, you need to think about both/all OSes when considering the clock, and i like to recommend that the OS you use most on any multi-boot box be the ONLY one set to roll the clock for DST
 
Old 11-06-2004, 04:37 PM   #10
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 15.0 (multilib)
Posts: 1,356

Original Poster
Rep: Reputation: 76
Thanks. I have reset the date in linux is advised by comprookie2000 and turned off automatic DST changing in Windows. The times are right now in both.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 09:58 PM
Doub about `net time set` and daylight saving time Thakowbbery Linux - Software 0 10-17-2005 05:23 AM
DO NOT use Daylight Saving Time - how? EcceVery Debian 4 05-28-2005 02:21 PM
How to un-config automatic Daylight Saving Time? davi_cabral Linux - General 2 10-13-2004 02:57 PM
How to setup Daylight Saving Time erick Linux - Software 1 10-15-2003 09:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration