-   Linux - General (
-   -   CUPS v6 Windows Driver Printing Preferences--"Operation could not be completed" (

meself88 07-12-2006 12:49 AM

CUPS v6 Windows Driver Printing Preferences--"Operation could not be completed"
I have installed CUPS, Gimp-Print 4.2.7, Samba, and the Foomatic database and utilities on a Slackware 10.2 machine that I am trying to turn into a print server. The printer is an Epson Stylus Color 740, and the driver I have selected for it is "CUPS + Gimp-Print." After placing the necessary files (Windows PS drivers and CUPS v6 Windows Driver files) into /usr/share/cups/drivers/ and running "cupsaddsmb -h localhost -H localhost -a -v" with a "successful" message, I still cannot seem to get the windows drivers to work properly. When I connect to the printer in XP, it asks me to permit it to install drivers, and when I click yes it connects to the printer with no messages. However, when I try to access the Printing Preferences menu, I get the message "Operation could not be completed." Trying to access the printer properties yields the message "The 'EPSON_Stylus_COLOR_740_USB_1' driver is not installed on this computer. Some printer properties will not be accessible unless you install the printer driver. Do you want to install the driver now?" Clicking yes pops up a search for a .inf file to install the printer. Clicking no actually takes me to the printer properties dialog, but the butten for printing preferences is missing. In the "Advanced" tab, there is a drop-down menu for the printer driver, in which it currently says "EPSON_Stylus_COLOR_740_USB_1." Can anyone give me any suggestions as to why my setup may not be working?

My other option is to set "use client driver = yes" in smb.conf and use Epson drivers on all the WinXP machines, but that seemed to cause problems with the printer getting disconnected and having to reinstall/reboot to get things working again. I would much prefer to let the CUPS server do the processing.

meself88 07-12-2006 07:44 AM

I have resolved the problem. For everyone else's benefit, I changed "guest ok = yes" in smb.conf and I also removed the .ppd file from /etc/samba/drivers that cupsaddsmb put in there and replaced it with the one from /etc/cups/ppd (the unmodified .ppd for my printer).

All times are GMT -5. The time now is 01:00 AM.