Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 02-03-2012, 04:52 PM   #16
Registered: Feb 2009
Posts: 282

Rep: Reputation: 54

5) I modified /boot/grub/grub.cfg as follows:
Your fix will work until update-grub is run by you or by a script.
For it to work permanently, you should modify /etc/default/grub.
You can edit the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" , deleting the words quiet splash. Also change or insert the line
GRUB_CMDLINE_LINUX . . . to read
or whatever option(s) you want

Then run update-grub. This will give an aesthetically pleasing scroll of boot processes.
At least that's the way it used to be. I gave up on Grub2 and use "legacy" Grub, which is much simpler and more convenient, in my opinion.

Last edited by impert; 02-03-2012 at 04:57 PM.
1 members found this post helpful.
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 02-03-2012, 06:46 PM   #17
Registered: Jun 2003
Location: Socorro, New Mexico
Distribution: Debian ("jessie", "squeeze"), Linux Mint (Serena), XUbuntu
Posts: 221

Rep: Reputation: 24
More permanent solution to the Ctrl-Alt-F1 to Ctrl-Alt-F6 blank screen problem

I tested impert's suggestions in detail and arrived at the following fix.
In interest of readability I repeat myself.

My five points are as follows:

1) I first discovered that Ubuntu does not use /etc/inittab ... so workaround suggesting modifications thereof are unhelpful.
2) Lack of inittab is not a problem if it turns out that getty is running. Do a top and check that getty or mingetty is running.
3) To be really sure getty is running, do ctrl-alt-f1 and assume you are at a login screen even though screen appears blank.
Log in as root (on Ubuntu I always enable root) and type reboot. For me it worked. That confirmed that I did
have a functioning terminal -- but it was invisible.
4) Modify /etc/default/grub looking to delete "quiet splash" as has been suggested several places and
make the following specific changes:
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  <-- Commented this line out
#GRUB_CMDLINE_LINUX=""   <-- And this one -- and added the following two lines:
5) As root, run update-grub and reboot.. Problem solved!

It is entirely possible that even more minor changes to /etc/default/grub will work ... but I only tested this far.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome crashes to black screen after boot up (though ctrl-alt-F2 gives a terminal) Gossamer Linux - Newbie 0 10-06-2005 01:32 AM
xscreensaver lock screen with Ctrl-Alt-Del kaon Linux - Software 2 07-13-2005 10:50 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 04:56 PM
Ctrl-Alt-F* Fiskarn Mandriva 2 10-15-2003 02:44 AM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:49 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration