LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   creating new partition before boot partition?? (https://www.linuxquestions.org/questions/linux-general-1/creating-new-partition-before-boot-partition-44098/)

nxny 02-06-2003 08:23 PM

>As it turned out, there were 2 problems: 1: cp -Rfa didn't copy all those little hidden config files and folders that are all over your home directory, i.e. the ones whose filenames are .something (how do you copy those, btw?? Other than one at a time, by hand, that is??

--Edited--
This is one of the less important reasons I discouraged you from keeping /home/laura in a separate partition instead of /home. Because we want to keep things simple and /home doesnt have files starting with the dot character.
--/Edited-

>and 2) I forgot that I'd copied all the files in /home over to the new partition as root...and when I tried to boot up as a normal user I didn't have rwx permissions on them, and I think that screwed me over just a little bit...well, now I know! :study:

Are you sure that you used cp -a? -a stands for 'archive' and implicity means -dpR . that should mean copy without dereferencing links, preserve attirbutes (permissions, access/modify time etc) and be recursive. (see cp man page.). That means, even if you ran cp as root, the files at the destination would still be owned by the original file owner.

use this
for i in $('ls' -A ); do cp -a $i /mnt/<wherever>; done

from the directory you want to replicate. Substitute destination.

Mind you, it wont work with files/directories with spaces in their names. You can tweak the script a bit to make it work, if you want to ;)

rose_bud4201 02-07-2003 10:47 AM

hmmm...I'm confused, now...should I or shouldn't I have moved /home in its entirety to the new partition? From your earlier post, it would be more of a faux pas to move just /home/laura, instead of /home...(since things work now, I'm not changing it again for awhile at least, but now I'm curious)

nxny 02-07-2003 12:25 PM

Sorry, I got it wrong in my last post. I have edited it.

Are you saying that the dot-files under /home/laura didnt get copied when you did a 'cp -a /home/* /mnt/newfs/' ?

If yes, there is something *seriously* wrong going on here. I just did it to make sure that I'm not going insane and it worked just the way I thought.


All times are GMT -5. The time now is 02:59 PM.