-   Linux - General (
-   -   Create bootable Flash Drive, Install Debian, Acer Aspire One (

jason_m 09-12-2009 08:48 AM

Create bootable Flash Drive, Install Debian, Acer Aspire One
In particular this post is about getting a Debian installer to boot from a USB drive. However, I am posting in General because I think the question is general enough and need not pertain only to a specific distribution.

For about a year I've had one of the 8.9in Acer Aspire One (AAO) netbooks that came with a linux distribution called linpus. For many reasons, I have found that I cannot maintain a linpus system and generally don't like how that computer came pre-setup and would like to start over. To do this I have chosen to install Debian.

The difficulty is that the machine has no CD drive. Thus, I was looking into booting the installer off of a USB flash drive. I found two references on how to set this up:

I ultimately ended up following directions from both articles. The methods in (1) failed for me, but (2) doesn't specifically mention the files I have.

I have a 8GB USB thumb drive I am hoping to use for the install. Method (1) failed in formatting the drive on the following command:
#mkdiskimage -F -4 /dev/sdg 0 255 63

Running that command produced the following error:
/usr/bin/mkdiskimage: 4: don't know how to determine the size of this device

I was unable to find much help doing a search for that error.

So, I turned to method (2) and my steps were as follows:
Partition the drive:
# mkdosfs /dev/sdg1

Run syslinux (to create a bootloader?)
# syslinux /dev/sdg1

Unzip the boot.img.gz file and copy it over to the USB drive:
$ gunzip <...>/boot.img.gz
# mkdir /mnt/usb; mkdir /mnt/loopback
# mount /dev/sdg1 /mnt/usb; mount -o loop <...>/boot.img /mnt/loopback
# cp /mnt/loopback/* /mnt/usb

After these command, my USB drive had the following files on it:
adgtk.cfg f1.txt f6.txt g2ldr.mbr linux stdmenu.cfg
adtxt.cfg f2.txt f7.txt gtk.cfg menu.cfg syslinux.cfg
disk.lbl f3.txt f8.txt initrdg.gz prompt.cfg txt.cfg
exithelp.cfg f4.txt f9.txt initrd.gz setup.exe vesamenu.c32
f10.txt f5.txt g2ldr ldlinux.sys splash.png win32-loader.ini

I added one more file, the net-installer image:
# cp <...>/debian-503-i386-netinst.iso /mnt/usb/

I then unmounted /mnt/usb and /mnt/lookback and tried to boot up the AAO off my flash drive. When the machine starts up, I press F12 to access the boot menu and select the USB drive as the boot device. The AAO tells me there is no table entry to boot from. (I don't have the exact error because of the next step I performed)

Article (2) at the bottom of the page mentions another step that may be necessary to get the device to boot, installing a MBR. So I performed this step:
# install-mbr /dev/sdg

Again tried to boot the AAO off the drive, this time I was presented with the message:

where the _ was a blinking cursor, but it didn't seem as though I could type anything there.

Any thoughts as to where I could be going wrong? I have never tried to setup a USB drive to boot off of, so I could be making a simple, silly mistake somewhere. Let me know if there is anymore useful information that I could provide.


jason_m 09-12-2009 01:37 PM

I was able to get my USB drive to boot. I should have thought of the solution sooner. I ran trusty old cfdisk on it. The single partition did not have the boot flag present, so I added it.

I guess I was just too new to syslinux and the mkdosfs scripts to think straight. I still don't know how others are able to succeed with the directions below. Could it be that some USB drive come with a bootable partition? I would have though more people would have encountered the same error as me.

All times are GMT -5. The time now is 03:57 AM.