-   Linux - General (
-   -   Create a Floppy/CD to boot into a hard drive install? (

DumberDrummer 01-31-2007 08:58 PM

Create a Floppy/CD to boot into a hard drive install?
Ok, I recently took an old POS box and decided to turn it into a fileserver. In the process of installing linux, I noticed that the hard drive, while detected under the install CD, was NOT detected under BIOS. This puts forth the problem of being unable to boot from that hard drive.

I've done everything I can to get this drive detected, and it simply won't be. So the question I have is, is there a way to install grub or something to a floppy with IDE support so it will boot into it, or chainload to the grub on the drive's MBR or something?

I've already tried several different boot/rescue CDs, including a CD with grub installed that worked as advertised, but apparently relies on the BIOS for hard drive info.

any help would be greatly appreciated.

MS3FGX 01-31-2007 09:56 PM

You can do this, but it may or may not be automated for you depending on the distribution.

For example, Slackware will give you that option on install. To either install LILO to the MBR of the drive, or install it to a floppy which you would then boot the computer with.

For all the details on doing this manually, you can look right here on the LQWiki.

DumberDrummer 01-31-2007 10:54 PM

Nothing at all on that page works. I tried grub and lilo and the other one previously, and Gujin doesn't detect my hard drive either

MS3FGX 01-31-2007 10:57 PM

That is pretty strange. What sort of errors do you get when you are using LILO? I am almost positive that does not use the BIOS for anything.

You couldn't get it to work with Smart Boot Manager either?

dgar 02-01-2007 08:11 AM

Get a GRUB floppy image and boot with that.

Then use GRUB to discover and boot the kernel and initrd on the hard drive.

First hit on google:

It'll go something like this in GRUB's command line:
root (hd0,0)
kernel /<hit tab a lot to find and fill out vmlinuz> ro root=/dev/hda1 vga=1
initrd /<hit tab a lot to find matching initrd.*.img>

dgar 02-01-2007 08:12 AM

Old school:
dd if=/boot/vmlinuz of=/dev/fd0
There was some tool to modify the vmlinuz binary to change boot and root stuff. I've forgotten it.

Linus originally made the kernel itself a bootloader. It has never since changed. With a carefully crafted kernel yo can even flash it to the motherboard's bios!

DumberDrummer 02-01-2007 05:31 PM

dgar, as stated, GRUB doesn't work....

I tried LILO again, and apparently the boot.b file that it calls for is missing? Lilo is for sure installed, but I can't create a boot disk following these instructions.

saikee 02-01-2007 06:27 PM

I am amazed by the statement that the Bios can't detect the hard disk but an installation CD can.

The installation CD relies on the information from the Bios.

For creating a bootable CD just follow the Chapter 3.1 of the Grub Manual. In a nutshell it involves dd two files called stage1 and stage2 files into a floppy. The stage1 and stage2 can be "sourced" from any Linux Live CD that supports Grub.

When you boot up this Grub floppy just type

geometry (hd0)
geometry (hd1)
geometry (hd2)

which will display all the partitions of the 1st disk (hd0), 2nd disk (hd1) and 3rd disk (hd2) and so on.

If Grub can't see it you haven't got one chance in hell to boot it by Grub.

At this point Grub is loaded but no Linux kernel around. Thus Grub deals directly with your hardware.

If you claim the installation CD can see your hard disk that mean you can install a Linux inside, right?

You can ask the Linux boot loader to duplicate a bootable floppy.

If it is a Lilo the command is

lilo -b /dev/fd0
If it is a Grub the the equivalent command is

grub-install /dev/fd0
The above is a copy of the boot loader to allow a user to boot the installed Linux from a floppy.

dgar 02-01-2007 07:16 PM

I would also double-check the master/slave settings on all hard drives and cdroms.

I've seen even correctly jumpered drives in combination of certain cdrom drives not work --even on different channels.

I would concentrate on the see-drive-in-bios issue first. Try a bare-metal boot: remove everything but memory, cpu, vga card, and a the target drive all alone on the ribbon cable. Then try reseting the bios ( pull the battery if you have to )

All times are GMT -5. The time now is 10:32 PM.