-   Linux - General (
-   -   cpu usage lags the puter w/rh9 (

Goofee 07-29-2003 10:44 AM

cpu usage lags the puter w/rh9

I recently installed redhat 9 and am experiencing lag once in a while !!!

When i start applications or surf web pages in gnome the computer uses up to 100% cpu for a short moment and lags at the same time. The music chops, the video in mplayer lags and the response in the menus turn slow for a short moment, before cpu usage goes down and everything is normal again.

Is all this normal in redhat 9? Is it this demanding? Do i need a faster cpu or is this some kind of i/o trouble perhaps?

I've installed all the lastest nforce-drivers but no change. My computer is a Athlon 1000mhz with 512mb and 40 gb wd hd. The mobo is a Asus a7n266-vm. All of this worked fine with winxp.

Please, does anyone have any tips?

rgds, Goofee

jvds 07-29-2003 10:46 AM

It sounds like the disk is slow. Assuming you are using ide what does

hdparm /dev/hda say?


Goofee 07-29-2003 10:53 AM

It says this:

multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 4865/255/63, sectors = 78165360, start = 0

It's using dma so it should be running ata-100 i think.

Goofee 07-29-2003 10:57 AM

And also this with hdparm -Tt /dev/hda:

Timing buffer-cache reads: 128 MB in 0.77 seconds =166.23 MB/sec
Timing buffered disk reads: 64 MB in 2.52 seconds = 25.40 MB/sec

Goofee 07-29-2003 11:52 AM

I tried to turn IO_support to 32 as well with hdparm -d1 /dev/hda, but the problem is still there. Could this be a kernel problem? I've read this several places. If not, my next step seems to be buying a new cpu.


jvds 07-29-2003 12:39 PM

It looks all ok..Do you know what FS you are using as it shouldn't be spiking..Does it do it just as the CLI rather than having X running?


Goofee 07-29-2003 01:00 PM

I cleaned up alot of services that weren't in use and my memory usage went from 512 mb to 160-250 mb. I noticed it got a little better, but it still lags in X.

Well in top X, mozilla and the Xs drain max 60%, but in the X system monitor it still peaks. Maybe if i turn of same fancy graphic effects and stuff in gnome it will help.


Goofee 07-29-2003 01:33 PM

Can't find anything to "tone" down gnome.

I think the only solution to this is to buy a faster cpu or to change window manager to something other than gnome.


fancypiper 07-29-2003 01:44 PM

Strange. :confused: I only notice mine chugged down when I am doing really heavy disk file movement or burning CDs. My cpu usage runs at 100% usally (I keep finding neat programs to compile) and my music keeps on playing as happy as if were the only program running. This is with Red Hat 7.3, and a Duron 950 with 512 MB ram.

You could tweak the kernel for better X responsiveness. See The Linux kernel preemption project, for example.

Goofee 07-29-2003 02:13 PM

My problem was that my memory was full (because of all the services i didn't even use!), so it started to swap. Now the audio/video seems ok, it's just sluggish in mozilla now and that i can live with until i buy a better processor or change to IceVM or something.

Thanks for your tips!

fancypiper 07-29-2003 02:37 PM

Try opera or galeon. I think the newest version lightweight mozilla based browsers is firebird-mozilla

Goofee 07-29-2003 02:45 PM

Hey yeah, you're right! i'll try it, thanks again! :)

DrOzz 07-29-2003 02:50 PM

when you run "top" in the terminal do you see anything eating up your memorY?
i seen a couple times where "magicdev" was sucking a box's resources and once it was killed there was no lag...
so just try "top" and see if you notice anything unusual..

Goofee 07-29-2003 02:59 PM

Well actually magicdev, mozilla-bin, nautilus, xmms, x and gnome-panel pop up once in a while and my memory usage is now up to 366mb already! darn it!

How did you stop magicdev? Can find it as a service.

Goofee 07-29-2003 03:09 PM

This is like windows, it eats up all my memory for nothing. X is using 274 mb for itself.

All times are GMT -5. The time now is 07:04 PM.