LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Corrupted ext3 Filesystem. How do I fix it? (https://www.linuxquestions.org/questions/linux-general-1/corrupted-ext3-filesystem-how-do-i-fix-it-144524/)

Apollo77 02-10-2004 03:18 PM

Corrupted ext3 Filesystem. How do I fix it?
 
I've been searching for how to fix my corrupted filesystem with little success. I tried "shutdown -r -F" -- didn't work. I'm running Fedora Core 1. Filesystem is ext3. Here's a screen dump:

[root@coolman root]# fsck /dev/sda2 -n -f
fsck 1.34 (25-Jul-2003)
e2fsck 1.34 (25-Jul-2003)
Warning! /dev/sda2 is mounted.
Warning: skipping journal recovery because doing a read-only filesystem check.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences: +9668870 -9668871
Fix? no


/: ********** WARNING: Filesystem still has errors **********

/: 201321/5183584 files (0.7% non-contiguous), 1015131/10361925 blocks
[root@coolman root]#


Everything seems to work fine. Should I even be concerned about this?

Thanks,
Apollo

Quis 02-10-2004 03:32 PM

make a backup :).
theres no hint i can give except this one.
i can tell you: do a e2fsck with wrong options brought my nearly full harddrive to lost+found.
be carefull <lame> :)

Apollo77 02-10-2004 04:25 PM

Already been there. Fortunately, I am running this copy of Fedora under VMware. When I mess up, I just restore a previous good image and my mistake is gone.

Filesystem still corrupt. Any suggestions?

jazernorth 02-10-2004 04:37 PM

try:
Code:

fsck -t ext3 /dev/sda2
Why do you have -f and -n? They are not, at least according to the documentation I have, valid switches. Also, switches belong before the filesystem name.

JN

320mb 02-10-2004 04:43 PM

heh, the only 2 times I tried installing Gentoo and/or Debian, the ext3 file system got fubar'd and rendered my drive useless......had to go to the H/D mfg website and download some tools to a floppy and let the tools fix the drive...........IE.....I lost everything on the drive itself.......luckily I had all data "backed up"

good luck........

Apollo77 02-11-2004 03:23 PM

Obviously, using different versions, jazernorth. Here are the options on my version:
-----------------
Usage: fsck.ext3 [-panyrcdfvstDFSV] [-b superblock] [-B blocksize]
[-I inode_buffer_blocks] [-P process_inode_size]
[-l|-L bad_blocks_file] [-C fd] [-j ext-journal]
[-E extended-options] device

Emergency help:
-p Automatic repair (no questions)
-n Make no changes to the filesystem
-y Assume "yes" to all questions
-c Check for bad blocks and add them to the badblock list
-f Force checking even if filesystem is marked clean
-v Be verbose
-b superblock Use alternative superblock
-B blocksize Force blocksize when looking for superblock
-j external-journal Set location of the external journal
-l bad_blocks_file Add to badblocks list
-L bad_blocks_file Set badblocks list
-----------------------

Thanks for your input -- confirms what I suspected -- time to start over. This was a relatively new install anyways. No data lost.

Apollo

yanik 02-12-2004 11:55 AM

This might be the journaling system of ext3 that is corrupted. You might want to mount it as ext2 and see if you can save some DATA.


All times are GMT -5. The time now is 08:34 PM.