LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-03-2003, 12:35 PM   #1
industrai
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
correctly mounting an NTFS drive


Hi all,

running mandrake 9.1

I must be root to mount my ntfs partition. When I do it, only root has access to it. How can I allow other users access to it?

I've tried chmod 666 /mnt/hdb1, no go.

Thankyou

industrai
 
Old 11-03-2003, 12:37 PM   #2
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 75
You would probably get more answers in one of the other sections (Distributions -> Mandrake perhaps?), since this is a security board.
 
Old 11-03-2003, 01:03 PM   #3
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 47
Try adding a 'umask=0' in the list of options in the line for /dev/hdb1. Ex:
/dev/hdb1 /some/folder ntfs umask=0,ro 0 0
 
Old 11-03-2003, 05:13 PM   #4
guardian653
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 79

Rep: Reputation: 15
I wouldn't write to a NTFS partition in Linux, as the drivers out there are still really buggy....
 
Old 11-03-2003, 05:44 PM   #5
industrai
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Im not writing to NTFS. I need users other than root to access (read only) the mounted NTFS partition. When a user logged in tries to access it, they get an access denied error.

I've tried to mount it as the user too, but I get a message that says only root can do it.
 
Old 11-03-2003, 06:12 PM   #6
guardian653
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 79

Rep: Reputation: 15
oh. but If I remember correctly, if you want users to be able to mount a partition, in your /etc/fstab file:

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

(just an example)

in the 4th field add "users" if you want to allow users to mount, unmount the partition
 
Old 11-05-2003, 07:51 AM   #7
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 47
The 'umask=0' option sets permissions for Windows drives. Since they don't support them, it has to be specified in fstab.
 
Old 11-05-2003, 10:59 AM   #8
Flibble
Member
 
Registered: Mar 2002
Distribution: Redhat 9.0, Debian, Knoppix, YellowDog
Posts: 142

Rep: Reputation: 15
mount -t smbfs //<server>/<share> /mnt/<mount> -o username=<user>/<production>,password=<password>,fmask=666

Should do it.


Flibble
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting USB NTFS drive. aje Slackware 13 03-23-2005 04:51 AM
slackware 9.1 mounting problems (cd drive, cd writer drive, win partition (ntfs)) mr.gizm0 Slackware 8 05-11-2004 07:23 PM
Mounting an NTFS drive e_cubed99 Linux - Newbie 11 11-01-2003 03:05 PM
Mounting a ntfs drive? mpooley Linux - Hardware 12 12-11-2002 01:32 AM
mounting ntfs(xp) drive elpresidente Linux - Hardware 7 07-01-2002 10:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration