-   Linux - General (
-   -   Console display error (

darin3200 08-12-2004 04:11 PM

Console display error
I just did a fresh install of Gentoo 2004.2 using Gentoo 2.6.7 kernel sources and did an install of 6.7.0-r1. When I boot up tty1-tty6 all look great and are perfectly functional. However when I issued the 'startx' command as a normal user X runs fine but tty1-tty6 are all messed up. To elaborate on 'messed up', nothing can be seen on the top half of the screen while on the bottom there are blocky vertical columns. When my typing should get down to there I can see that I'm typing something on the bottom half of the screen but I can't tell what. Killing X also does not help. I also compiled a large amount of frame buffer support into the kernel but I avoided compiling in anything that was experimental.

How should I go about fixing this problem.


Tinkster 08-12-2004 04:50 PM

Come on Guru (congrats, btw, didn't notice the
new status earlier),

Where's the info about the hardware we're looking at? :)


darin3200 08-12-2004 05:38 PM

Thanks. Your question actually solved my problem. I went to check out the hardware specs and I changed some of the xorg.conf. I have an SiS 740 and I was running it on an SiS 620 driver. X worked fine so I thought I wasn't a driver issue. I have changed the driver to a Generic VESA and now it works. I'm still confused why running X on a different driver would have any effect on my console though. :confused: I guess I'm still a newbie when it comes to X though :)

All times are GMT -5. The time now is 10:12 AM.