LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-16-2003, 12:49 AM   #1
suriyamohan
Member
 
Registered: Mar 2003
Location: Coimbatore
Posts: 50

Rep: Reputation: 15
Smile Configuration error while running atk-1.2.0 package


Hi,
I tried to install atk-1.2.0 package in my system. While running "./configure" the program stopped abruptly and displayed that a newer version of glib is required. The output shows that GLIB - version >= 2.0.0 is required. But there exists GLIB version 2.2.0 in advance. so i installled GLIB 2.0.3. Again the following error occurs.

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.3, but GLIB (2.2.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.

1) Which is the older version and how to remove the same ?

2) I added the following 2 lines to \etc\ld.so.conf file.

/usr/local/lib
/usr/local/include

And executed the file as " ldconfig \etc\ld.so.conf " at shell prompt. Is this is correct?

3) How to modify LD_LIBRARY_PATH enviroment variable ?

4) How to set the environment variable PKG_CONFIG_PATH to point to the correct configuration files ?

Help me how to overcome the aforesaid problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuration Error when running ./configure for gnucash cddesjar Linux - Software 2 04-28-2005 10:56 PM
Help!!! How to install GLib, GTK, ATK and Pango, just to get Firefox running. LOL RJARRRPCGP Linux - Newbie 7 11-20-2004 05:42 PM
ATK package??? ljr2600 Linux - Software 3 09-12-2004 04:43 PM
ATK make error k4zau Linux - Software 0 02-11-2004 07:38 PM
Error Installing ATK (Accessibility Toolkit).. suriyamohan Linux - Software 1 06-13-2003 04:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration