LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-30-2003, 10:16 AM   #1
SoSlack
LQ Newbie
 
Registered: Apr 2003
Posts: 12

Rep: Reputation: 0
Computer wont really turn off... just "Power Down"


I've just recompiled my kernel and I've said YES to APM.
But now my computer wont shutdown when I do:
shutdown -h now
My computer is a Dell X200 (Laptop)
and running Slackware

BTW. My sound doesnt work either. When using XMMS, mp3's look like they are playing cause the equilizer is moving. But no sound????

Thanks!
 
Old 04-30-2003, 10:39 AM   #2
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 49
Are you running apmd? Just because the kernel supports APM doesn't mean it's getting any messages concerning APM. The userspace to kernelspace communication has to occur, and that's facilitated by apmd. Read the man page on how to set up apmd.
If you are already running apmd, either the configuration is not correct or your hardware doesn't support APM. It might support ACPI, though.
 
Old 04-30-2003, 10:40 AM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Does a poweroff work?

Did you check your volume for sound? And the permissions haven't changed or are ok on the /dev/dsp and /dev/mixer devices?
 
Old 04-30-2003, 11:11 AM   #4
Nukes
Member
 
Registered: Apr 2003
Location: Scotland UK
Distribution: Gentoo
Posts: 92

Rep: Reputation: 15
Make sure you have the sound card set up right, and the volume is not at zero tell XMMS to use master instead of PCM and see if that helps. When you said yes to APM, did you also say yess to "Use real mode BIOS call to power off the computer" That normally fixes it.
 
Old 04-30-2003, 02:45 PM   #5
markus1982
Senior Member
 
Registered: Aug 2002
Location: Stuttgart (Germany)
Distribution: Debian/GNU Linux
Posts: 1,467

Rep: Reputation: 46
Well use lsmod to check if the apm module is loaded. If it is unload it using rmmod! Load the module using ismod apm power_off=1 and try shutdown -h now

If this works (like it should), all you need to do is change your module configuration - like /etc/modules in Debian :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there any way to turn off the computer power without pushing the button? Necronomicom Slackware 11 02-27-2006 03:50 AM
Power Wont turn off automatically marigb Linux - Hardware 5 11-16-2005 08:08 PM
Press power button can't turn down the computer shadkong Linux - Hardware 2 05-04-2005 09:50 PM
What "kernel opts" allow PC to power down with "turning energy off"? kornerr Linux - General 1 03-10-2005 12:07 PM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-06-2005 11:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration