-   Linux - General (
-   -   'Compose' key not working (

Doug Hutcheson 01-11-2013 11:15 PM

'Compose' key not working
I have previously set up my FC17/Lenovo Think Pad system to use the Menu key as the Compose key, as per this suggestion.

It worked perfectly, allowing me to type such combinations as Menu,o,c to create the copyright symbol .

Today, I had cause to use it again and found it no longer works. The layout options under System Settings/Keyboard clearly show the position of the Compose key as being the Menu key, but this is having no effect: the Menu key brings up whatever menu is currently in context.

I tried adding the Windows key as a Compose key, but it also did not work: it still toggles the display of my various windows, instead of letting me compose characters.

It used to work, the setting is still there and I have not changed keyboards. What am I doing wrong?

DavidMcCann 01-12-2013 11:56 AM

I don't know why it stopped, but we might get it going again! Try this in the command line:
setxkbmap -option compose:menu
If that works, put it in ~/.xsessionrc

If that fails, try editing /usr/share/X11/xkb/symbols/pc and replacing
key <MENU> {[Menu]};
key <MENU> {type[Group1]="TWO_LEVEL", [Multi_key, Multi_key]};
Make a backup first!

Doug Hutcheson 01-13-2013 02:39 AM

Excellent advice, thank you DavidMcCann. Executing 'setxkbmap -option compose:menu' from a command line makes Writer recognise Menu as the Compose key. I have created ~/.xsessionrc and placed the command there.

Thanks for your help.

All times are GMT -5. The time now is 04:50 PM.