Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 03-12-2009, 08:59 AM   #1
LQ Newbie
Registered: Aug 2008
Posts: 5

Rep: Reputation: 0
Clocksource tsc unstable


I'm running Debian Lenny stable on an AMD64 processor (Athlon X2) on an Asus M2A-VM motherboard. We use the machine as a server for our website. We had a lot of instability issues (every few days the kernel locked up in a hard panic which required a manual reset of the system) before the upgrade to Lenny. I already ran memtest86+ for 48 hours without any error so i guess the memory isn't corrupt.

Since I installed lenny, i'm getting a new error in the dmesg output:
[ 2494.398691] Clocksource tsc unstable (delta = 62507982 ns)

after it has run for about half an hour. It keeps running but it locks up again after a week or two, and a lot of kernel Oops'es (which can be seen in the kernel.log file). The clocksource message is reproducible every half an hour after boot, reason unknown. I have been looking up a lot of information and forums on this matter but i can't seem to find what's wrong. In the kernel.log file, when an Oops occurs, there is an error for one specific Perl script that renders a page on the website, something i haven't seen before in the logs.

What I have attempted so far:
- installed the latest BIOS version
- Linux version 2.6.26-1-amd64 (Debian 2.6.26-13) ( (gcc version 4.1.3 20080704 (prerelease) (Debian 4.1.2-24)) #1 SMP Sat Jan 10 17:57:00 UTC 2009
cat /sys/devices/system/clocksource/clocksource0/available_clocksource
hpet acpi_pm jiffies tsc
cat /sys/devices/system/clocksource/clocksource0/current_clocksource
This is the same before AND after the clocksource message.
- i haven't tried enabling or disabling kernel boot options yet.

Can someone give me any help on this?
Old 07-25-2009, 10:46 AM   #2
Registered: Aug 2003
Distribution: Debian Testing / kubuntu
Posts: 86

Rep: Reputation: 21

Try adding the following option to your kernel line in the boot loader:


The message "tsc unstable" still appears on boot up. But the boot process doesn't hang any more after the message.

In more detail, if you use grub:

Edit /boot/grub menu.lst

find the line

## ## End default Options ## ##
Just after this line, the first boot option should appear.

On the line starting with kernel, add clocksource=acpi_pm at the end.
Looks like this on my system:
title           Debian GNU/Linux, kernel 2.6.26-2-amd64
root            (hd0,0)
kernel          /vmlinuz-2.6.26-2-amd64 root=/dev/mapper/lvmgruppe-root ro clocksource=hpet
initrd          /initrd.img-2.6.26-2-amd64

Last edited by mad4linux; 07-26-2009 at 04:59 PM. Reason: changed content


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
time: pit clocksource has been installed rabbit2345 SUSE / openSUSE 2 05-29-2011 07:09 PM
Check available clocksource? kushalkoolwal Linux - Kernel 2 02-22-2010 03:56 PM
Clocksource tsc unstable punt Fedora 11 12-29-2008 04:16 AM
Unstable Clocksource with SMP kernels after 2.6.20 thesk8ingtoad Slackware 4 08-15-2007 03:19 AM
is ubuntu unstable less unstable than debian unstable? lefty.crupps Ubuntu 9 10-14-2005 02:38 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:27 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration