LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 07-10-2001, 06:49 AM   #1
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Rep: Reputation: 15
Thumbs down Clock 4 hrs off at start up


I need a little help, I'm running Mandrake 8.0 and ever since I installed drivers for my soundcard when ever I start the computer in Linux or Windows my clock is exactly 4 hrs slow. I've checked my time zones in both OS's and there o.k. any ideas would be greatfull.
 
Old 07-10-2001, 07:11 AM   #2
cinnix
Member
 
Registered: Jun 2001
Location: Northern Ohio
Distribution: RedHat, Engarde and LFS
Posts: 237

Rep: Reputation: 30
Check the BIOS time.
 
Old 07-10-2001, 07:35 AM   #3
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 47
Post a related comment

Just thought I'd mention (cos it catches loads people out) that if you use the date command to set your date/time that this only affects the software clock. If you were to reboot then you'd be back where you where before using date. After using date you need to use the hwclock command with some flag (check 'man hwclock' and 'man date' for all the flags/switches) [that I can't remember at the moment] to save the setting to the hardware clock on the system. The hardware clock is normally only referenced at boot time, then a software clock takes over, hence they can be two completely different times!

cheers

Jamie...
 
Old 07-10-2001, 06:34 PM   #4
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Original Poster
Rep: Reputation: 15
cinnix, yea the BIOS clock was off by 4 hrs (ahead) and when I boot into Linux the clock is 4 hrs behind. I think I need to pick up a battery.

jharris, I messed around with hwclock but could not set time (still a newbie at typing commands) I would type "hwclock -s" but nothing happened ?
 
Old 07-10-2001, 06:50 PM   #5
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
sounds like linux is expecting gmt from the bios instead of local time. if you set the bios clock to correct local time is linux 8 hours behind?
 
Old 07-10-2001, 07:00 PM   #6
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
There is the option to set linux to look for the bios hwclock to use GMT so if this is true and you have your local time in the OS then it sounds like you are off by your local time difference from GMT. If you selected GMT - 8 hours then if your bios time is set to local time you will be off by 8 hours.

In my Unix system this is in a file called time.

If you are dual booting with windows and you want local time you need to have Linux look for the bios to have local time. I don't know where it is at, but someone here should have the info to do that. Or you may try to search the internet for it.




Last edited by DavidPhillips; 07-10-2001 at 07:08 PM.
 
Old 07-11-2001, 02:47 AM   #7
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
And when you get the GMT/Local thing figured out you can go out and get netdate. Then do a
Code:
netdate timelord.uregina.ca
to set you clock to proper time. Then when you get the correct time try
Code:
hwclock -w
to set your hardware clock.
 
Old 07-11-2001, 06:26 AM   #8
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Original Poster
Rep: Reputation: 15
update, today must be my lucky day when I fired up Windows it started with the correct time. rebooted into Linux and it was off by 4hrs (slow), messed around with 'hwclock' and the time is correct so far, after rebooting twice just to make sure. I think I'm going to keep a eye on this and if it messes up again i'll toss in a new battery. Thanks for everybodies help. I'll be back with more questions as I learn this new OS.
 
Old 07-15-2001, 08:20 PM   #9
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Original Poster
Rep: Reputation: 15
Well It's me again, here's the lowdown so far on this time problem, the culprit is KDE, if I log in to Gnome the time is O.K.,If I reboot into windows it set the BIOS clock 4 hrs ahead. I've tried using the 'hwclock'command but no luck is there a directory I can edit to straighten this out? any help greatly appriciated. Thanks in advance again.
 
Old 07-15-2001, 08:25 PM   #10
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
there's a date and time config window in the kde 'control center' under the system tab it also allows you to set the time zone.
 
Old 07-15-2001, 08:38 PM   #11
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Original Poster
Rep: Reputation: 15
rshaw thats been done and it works until I restart my computer,as long as I stay in linux it will work. There has to be a file some where I can edit because I can go from KDE(with the time off 4hrs) to Gnome and the time will be right on.
 
Old 07-15-2001, 08:52 PM   #12
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
i think it's a bug in 'kclockapplet'. there are many bug reports on this at kde.org. have you ran mandrake update to see if the is a bug fix package available?
 
Old 07-15-2001, 09:03 PM   #13
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Not too sure 'bout the other distros, but in SuSE I can change how the clock is configured. I'm guessing that your BIOS clock will be on local time since you'll be using Winders.
Code:
 grep "GMT" /etc/rc.config
# Set to "-u" if your system clock is set to GMT, otherwise "".
GMT="-u"
I'm guessing that it's the combination of the above and your timezone settings.
Code:
grep "TIME" /etc/rc.config
RC_LC_TIME=""
TIMEZONE="Canada/Pacific"
CATMAN_ATIME="7"
 
Old 07-16-2001, 07:17 AM   #14
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Original Poster
Rep: Reputation: 15
rshaw, I can't find Mandrake updates, I know in 7.2 it was on my desktop the only close to it is software manager.

mcleodnine,opened up a terminal but I have no /etc/rc.config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
less than 24 hrs into linux and i already broke something lejakl Linux - Software 7 07-31-2003 10:47 AM
2 day challenge starts in 12 hrs! slipsy Linux - Networking 5 04-20-2003 11:43 PM
Disconnect after 2 hrs on idle bernstar77 Linux - Networking 0 11-26-2001 01:37 PM
Redhat 7.0 - attempting to install it the last 72 hrs without success - PL HELP! prowzen Linux - Software 9 07-31-2001 06:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration