-   Linux - General (
-   -   characters mangled when using sftp (

werowe 10-29-2006 06:05 AM

characters mangled when using sftp

When I used psftp or filezilla to transfer text documents from my PC to my linux server the quote mark character is changed to a question mark. In VI these single characters are displayed as an escaped character such as ~S, ~R, or ~T.

I tried to add this to my .bash_profile but it did not correct this problem.

export LANG=en_US.ISO-8859-1
export SUPPORTED=en_US.ISO-8859-1

As it stands when I upload large documents I have written to my web site I have to hand edit each and every occurence of these quotation marks. The same thing happens when I use Spanish accents. Please help.

ganz_friedrich 10-30-2006 03:09 AM

Did you try looking for any related settings in your sftp programs? Not quite the same, but I remember that I use to have putty set to the wrong character set and I got the mangled letters - maybe the problem is on the client side.

werowe 10-30-2006 07:30 PM

There are no such settings in filezilla not sftp. I had no problems when I was using another Linux server. Something is different on this new Linux server with regard to codepage or character set.

All times are GMT -5. The time now is 02:14 AM.