-   Linux - General (
-   -   Centos wont let me install windows xp (

skinshaman 05-08-2007 08:09 PM

Centos wont let me install windows xp
Hello. I just got a computer, the guy I got it from put centos 4.4 on it. I am comfortable using windows and know nothing about linux. I tried to install a copy of windows xp home edition, and when the screen says "hit any key to boot from cd-rom",I do and the screen gose black and dose nothing. Would it be easier to format the hard drive and start from scratch? If so how would I go about formating the hard drive? Any help would be greatly appreciated

MS3FGX 05-08-2007 09:05 PM

That would have nothing to do with Linux being installed. Once the XP CD gets to the point where it asks you to hit any key to boot to the CD, it has already bypassed your HDD entirely and is now running from the CD-ROM itself.

The problem would likely be a bad CD or bad CD-ROM drive. But you could try reformatting if you like, though I am not sure how you intend on doing that when you can't boot to the CD in the first place.

syg00 05-08-2007 09:43 PM

Not (entirely) true. M$oft installers are very sensitive to the layout of the disk. It is easy to constuct scenarios (that Linux distros do) where the XP installer just quietly exits.

@skinshaman, we need a bit more info;
- are you planning on keeping/learning Linux ???
- can you log on to that Centos (userid and password o.k.) ???
- do you just want a working XP (i.e. blow Centos away completely) ???

If you can get on, go to (probably) Applications>System Tools>root terminal
and enter

fdisk -l
(that's a lower case ell, as in list). Let's see all the output.

phantom_cyph 05-08-2007 09:53 PM

Yes, display fdisk, and also, you may want to consider running Linux. CentOS is one of the most secure OS's on the "market". Dual-booting is an option, if not, you will have to reformat your drive. See GParted.

skinshaman 05-09-2007 06:00 PM

syg00 - I am trying to erase centos all together and install windows. centos will let me log in and seems to run fine, but all the programs i am used to running are windows based. I realize you can run a both os's but I am pretty computer illiterate and am not familiar with centos or any linux based software. Thanks for your help.

phantom_cyph 05-09-2007 06:09 PM

OK then. Since you seem to think the windows CD is not being allowed to boot because of CentOS, download GParted. Use K3B (install it by opening a terminal and typing "yum install K3B".) to burn the image to a disc (at 4x-16x). The disc needs to be a CD-R, not RW. Then, stick it in your tray and reboot. The boot options are simple, to stick with English, just hit enter all the way. It boots into a GUI (graphical user interface) and from there, things are pretty self explanatory. Just select all the partitions and press delete. Then, install Windows. (if you want to, you can make an NTFS or FAT32 format for the whole drive-but Windows will do that itself).

Consider the possibility of your Windows disc being bad...

For further instructions on burning an iso to a CD, see here.

syg00 05-09-2007 06:23 PM

Fom a (root) terminal window in Centos, enter this (carefully)

dd if=/dev/zero of=/dev/hda bs=1 count=510
You will lose access to*everything* on the disk. But it'll be seen as uninitialized on the CD re-boot.

If the command fails, try /dev/sda instead (on the of=).

skinshaman 05-12-2007 03:46 PM

syg00- I tried both of those comands and they didnt work. I logged in as root, went to terminal tried both comands. When I tried the first comand it seemed to give me a breakdown of what each part of the code ment, but didnt do anything further. So I tried the second code and it said it didnt recognise the comand 'cont 510'. The first comnd seemed to respond but I dont know what to do from that point.

Emerson 05-12-2007 05:39 PM

May it be you have some "virus protection" feature enabled in the BIOS which denies writes to the MBR?

syg00 05-12-2007 06:53 PM


Originally Posted by skinshaman
When I tried the first comand it seemed to give me a breakdown of what each part of the code ment, but didnt do anything further.

That's probably a help screen - you mistyped the command; "copy-and-paste" the command would be best. If you see the same thing again, <shift><pgup> allows you to page up and see the start of the error message.

So I tried the second code and it said it didnt recognise the comand 'cont 510'.
sounds like you got a ";" in there - and split the command line into two commands.
BTW, that should be "count=510", not "cont 510".

All times are GMT -5. The time now is 04:30 PM.