-   Linux - General (
-   -   CD's no longer boot after installation (

lachesis 06-19-2007 08:08 AM

CD's no longer boot after installation

I have a strange problem. I recently installed Red Hat Enterprise 4 on my system and am having difficulty getting the Marvell adapter working, even with the compiled kernel support.

So I went to reinstall windows and now my laptop won't boot from any other CD - only if it is the Red Hat CD.

It gets to:

'Press any key to boot from CD'

which I do then it gets to the next screen:

'Setup is inspecting your computer's hardware configuration...'

And then the computer goes black. I have tried two different working CD's, I have plugged in a different USB CD Drive and booted from that with the same result. I have also tried Hiren's boot CD and other disks but all have the same effect - they just get to that stage and halt.

But the linux one boots fine - anyone help me out?


Emerson 06-19-2007 08:30 AM

Yep, you are doomed now. The only OS this laptop will ever boot is Linux from now on. Do not place it near other Windows computers, they may get infected. ;)

Seriously. Windows setup will show you black screen when it does not understand your HDD layout. Try to boot up with a Linux CD and delete all partitions. If this does not help you may need to overwrite the beginning of HDD with dd to make sure Windows thinks it is an empty HDD.

lachesis 06-19-2007 08:36 AM

OK thanks what is dd?

Also, I was just going to wipe the Linux partitions with the Red Hat cd but it always wants me to install again, beofre wiping - which Linux CD will allow me to just wipe all partitions?

Emerson 06-19-2007 08:43 AM

Doesn't RH have the rescue mode or something? All you need is the shell so you can run fdisk (adn dd maybe). dd is a very cool and useful UNIX utility which allows low-level access to the HDD.
Every Linux LiveCD can be used, Knoppix for instance.

lachesis 06-20-2007 04:29 AM

Hey thanks

I've downloaded Knoppix and read a bit about fdisk.

Can someone help me, as it says I should use another program than fdisk if other OS are meant to be used on the disk.

Is the syntax simply


fdisk /dev/hda1
then it will allow me to delete all partitions?


Emerson 06-20-2007 07:34 AM

fdisk /dev/hda
hda1 is a partition, you want to address the entire disk. You may find cfdisk more convenient to use.

All times are GMT -5. The time now is 02:59 PM.