LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-13-2003, 04:53 AM   #1
oiper
LQ Newbie
 
Registered: Dec 2002
Location: birmingham, al
Distribution: Gentoo mostly
Posts: 23

Rep: Reputation: 15
Red face CDR burning and LAG


When I've used gtoaster in the past to burn anything(Redhat 8.0 mostly), I never get "desktop lag". I can still browse the web or play patience solitare or something. I've tried some other burners, Arson, Xcdroast, and again gtoaster.... and I get these annoying bursts of lag while it burns(Now using VectorLinux). I expect SOME lag, but not anything more than what I used to get from gtoaster with RH 7.x and 8. Is there some tweak to keep it from utilitizing some much of my cpu or whatever it's eating? Or something I should change in my kernel? Any tips would be appreciated.

~using SCSI emulation
~cdrecord 2.0
~cdrdao-1.1.7
~and any burner
~having a hard time typingn at this very moment due to cd burning =P
 
Old 02-13-2003, 05:06 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
This usually has to do with DMA being enabled or not. Either on your harddrives or cdroms. hdparm is your friend. Either read the man pages or search on this site for hdparm. There have been many threads about it.
 
Old 02-13-2003, 07:51 AM   #3
acid2000
Member
 
Registered: Nov 2001
Location: Exeter, UK
Distribution: Gentoo 1.4
Posts: 243

Rep: Reputation: 30
Have you looked at the man page for cdrecord?
 
Old 02-13-2003, 03:08 PM   #4
oiper
LQ Newbie
 
Registered: Dec 2002
Location: birmingham, al
Distribution: Gentoo mostly
Posts: 23

Original Poster
Rep: Reputation: 15
i have read cdrecord. here is the output of hdparm on my HD and my burner:

hdparm /dev/hda gives:

/dev/hda:
multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 4870/255/63, sectors = 78242976, start = 0
-------------------------------------------------------------
hdparm -i /dev/hda gives:

/dev/hda:

Model=SAMSUNG SV4002H, FwRev=QP200-03, SerialNo=0358J1FRB19713
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=38997, SectSize=619, ECCbytes=4
BuffType=DualPortCache, BuffSize=1945kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=78242976
IORDY=yes, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2 udma3 udma4 udma5
AdvancedPM=no WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 1: 1 2 3 4 5 6
-------------------------------------------------------------

hdparm -t /dev/hda gives:

/dev/hda:
Timing buffered disk reads: 64 MB in 2.56 seconds = 25.00 MB/sec
-------------------------------------------------------------

hdparm /dev/hdc gives:

/dev/hdc:
HDIO_GET_MULTCOUNT failed: Input/output error
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
BLKRAGET failed: Input/output error
HDIO_GETGEO failed: Invalid argument
-------------------------------------------------------------

and hdparm -i /dev/hdc:

Model=LITE-ON LTR-48125W, FwRev=VS04, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:227,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no
-------------------------------------------------------------

So DMA is turned on for both. Should I try turning DMA off for the burner. Most places I've read say you want it on. Definitly on for the HD. Does this DMA setting even affect my burner while it's emulating SCSI?
 
Old 02-13-2003, 07:47 PM   #5
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
> So DMA is turned on for both. Should I try turning DMA off for the burner. Most places I've read say you want it on. Definitly on for the HD. Does this DMA setting even affect my burner while it's emulating SCSI?

Nope, I dont think so. DMA really helps to boost the read speed even under ide-scsi, but I'm not sure if it would affect the writing speed at all. What speed are you burning at? The next thing I'd do is reduce the writing speed so that the rest of your hardware doesnt have to grind hard to supply data to cdrecord as much as it has to now.

As you might have noticed from the manpage, cdrecord uses real-time scheduling which is at least on par with ( if not higher than ) kernel processes. Personally, I choose the highest write speed and leave the system alone until the CD is written.

In a possibly unrelated note, it your hard-drive could use one of the higher UDMA modes such as mode 5 ( -X69 )

Last edited by nxny; 02-13-2003 at 07:49 PM.
 
Old 02-14-2003, 09:50 AM   #6
oiper
LQ Newbie
 
Registered: Dec 2002
Location: birmingham, al
Distribution: Gentoo mostly
Posts: 23

Original Poster
Rep: Reputation: 15
I am burning at 48x, and have been able to in the past without this lag. Some other people out there have had this same problem, and someone suggested that the 2.4.18 kernel was the cause. I'm running 2.4.20 and I might just try something newer (but I don't really think this is the problem). But about trying a higher UDMA mode, when I boot into single user mode, that last thing it says is no more processes left at this level. ...so, could I make my HD unusable if I try -X69 in runlevel 3 and it doesn't like it? Could I recover from it in runlevel 3?
 
Old 02-14-2003, 02:01 PM   #7
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
48x. way to go!! I'm sure, cdrecord will hog most of your CPU cycles at that speed.

I read that you've been able to use gtoaster ( which I've never used ) at those speeds without the desktop lag. Do you know if it is a graphical frontend to a utility? Like Xcdroast using cdrecord internally.
 
Old 02-14-2003, 03:23 PM   #8
oiper
LQ Newbie
 
Registered: Dec 2002
Location: birmingham, al
Distribution: Gentoo mostly
Posts: 23

Original Poster
Rep: Reputation: 15
it is a front end for both cdrdao and cdrecord. I tested it last night and had the lag still! It's very annoying... If I get anywhere on this problem, I'm going to be sure to post it here and my website.

http://gnometoaster.rulez.org/
 
Old 02-15-2003, 02:07 AM   #9
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Hehe I had to chuckle a little, your complaining about lag.

My first burner was a 2x on a VLB SCSI card in a 486 and when I burnt CDs I'd not only not work on the computer but we would walk softly around the house and occasionally sacrifice a goat or two in hopes of not turning a $9US blank CD into a coaster.
 
Old 02-15-2003, 02:24 AM   #10
oiper
LQ Newbie
 
Registered: Dec 2002
Location: birmingham, al
Distribution: Gentoo mostly
Posts: 23

Original Poster
Rep: Reputation: 15
It's ok, I was waiting for a chuckle... or somebody to cuss me for complaining. I wouldn't complain, unless I hadn't ever had it "not" lag on me before. There's something odd going on and I'm sure in a few months it'll dawn on me...but till then, I'll just walk off i guess.
 
Old 02-15-2003, 03:01 AM   #11
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Writing at high speeds, causes the cdwriter to use up a lot of cpu resources. If you head over to cdfreaks.com and look at a few reviews of fast writers, you will see the cpu usage mushrooms at high writing speeds (and reading speeds).
 
Old 02-15-2003, 04:14 AM   #12
xcon
Member
 
Registered: Jan 2002
Location: Ohio
Distribution: Slackware 9.1 (and some 9.0)
Posts: 181

Rep: Reputation: 30
-X69 is good. very good.

just make sure BOTH the motherboard AND the drive say something in their packaging, docs, etc. about ATA-100 or UDMA 5 or UDMA 100 or Ultra ATA 100 or 133 or something to that effect.
according to your hdparm output, your drive (at least) will do it. check the board...

here's something to laugh at: I thought that -X66 was UDMA66 until I read the man page, and found out i was deliberately hitting the brakes every time in rc.local... ugh

however, certain things seem to make hdparm stop dead when you set certain other things... like having a System.map that was for a different kernel did it to me a while ago. then all you can do is ctrl+alt+del and let it reboot, then pass 'single' to the kernel to disable it until the weirdness is resolved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
request info on burning floppies to cdr aus9 Linux - Newbie 9 11-11-2005 08:52 PM
burning cdr (mp3 .cue) thing0 Linux - Software 2 08-28-2004 06:43 PM
lag in 2.6.3 doralsoral Linux - Software 1 03-28-2004 09:26 AM
audiocd burning problem, whole system hangs while burning ichbinesderelch Linux - Software 1 11-14-2003 02:30 PM
Burning tar on cdr connormcl Linux - Software 1 09-06-2003 10:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration