-   Linux - General (
-   -   cdburning problems (

schatoor 08-22-2002 05:24 AM

cdburning problems
Hello there,

I have a Phillips CD w/rw. The system automatically detected this during installation and setup the ide-scsi emulation for me.

Today, I tried to burn some mp3's on a CD. So I did :

mkisofs music.iso /some/directory

cdrecord -o dev=0,0 music.iso

This led to my kernel panicking (the caps-lock and scroll led's started blinking).

I did do scan of my scsi busses :

cdrecord -scanbus

It told me something like this :

0,0,0 0) 'PHILIPS ' 'CDD3610 CD-R/RW ' '3.01' CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

I can also not mount a cdrom if it is in the cd writer. This also leads to an kernel panic

What am I doing wrong ? I'm currently using SuSE 7.3 with a 2.4.10 kernel.

Please help me.


mrGee 08-22-2002 02:37 PM

i see two odd things in your cdrecord line;
i use dev=0,0,0 missing 0
and i don't use -o , for getting info i use -v
i often use this; cdrecord -v dev=0,0,0 speed=4 some.iso
speed depends on your cdrecorder.
for my mkisofs( well the one i use the most);
mkisofs -v -o some.iso -R -J /dirname
see man mkisofs
For your kernel panic; i don't know try some things; how
do mount it, you shouldn't mount a clean recordable before
Can you mount a normal data cd in your burner?
You mount it from console or gui ?
Check your /etc/fstab
And i had my share of troubles with a philips 4 speed cd-
recorder playing nuts on me. Some times it workes and
sometimes it crashes, like not burning anything. In W$
the thingy always works :mad: tried several distro's, turned
out to be hardware faillure.
Good luck

And living in a tiny country in a tiny place, makes you
feel humble don't you think; my town is even smaller ;)

schatoor 08-23-2002 04:18 AM

Hallo daar, ik zie dat jij ook uit nederland komt, gaaf !! Ik zal maar weer in het engels gaan schrijven voor de andere mensen.

For the folks who can't read the above lines, just ignore them.

Thanks for giving me pointers of how to make iso images and burn cd's. I never did this before under linux and I just tryed something without reading the man pages carefully. Maby I shouldn't of done that.
But I don't think doing it the way you told me to is going to solve the kernel panic. I think this because of two reasons.

1) I can't mount any thing if it is in the cd burners and i'm not talking about clean cd's. If tryed mounting in GUI as well as console, it just does not work.

2) I have tried buring with xcdroast. It doesn't give me a kernel panic but doesn't burn either. I just gives me error messages. As i'm writing this post at my university (and thus i'm not able to use my computer at home) I can't tell you what these error messages exactly were. I can tell you in a later post thou.

I can burn stuff under windows. Could you help me further ?

Thanx a million

mrGee 08-23-2002 06:24 PM

I tried some things on a suse 7.2 distro; it didn't set up
my ide-scsi and it didn't mount in gui either.
I guess the scsi emu won't be your problem cause you
can cdrecord -scanbus. But to make sure;
cat /proc/scsi/scsi should read out your burner.
and a dmesg|less should read out the append line in your
lilo.conf. (Kernel command line, ide_setup)
do a lsmod to see what scsi stuff is there. (be root)

Suse sets the icon for mounting the burner to /dev/cdrecorder
and this is wrong, change that to /dev/sr0 and use that in
console too.
mount /dev/sr0 /media/cdrecorder.

And i did a bit of googling on 3610 (
Some kernel and firmware related things showed up hmmm.
Check it but before trying, post some of the errors first
maybe someone with the same 3610 and suse has got some other info on that.
(do ctrl-f 3610 to see the exact part, also in dutch available)
so you see the links provide some info that are a bit confusing
And maybe try the supportdatabase in

schatoor 08-25-2002 05:59 AM

Hello there,

I did every thing you told me to. Doing lsmod showed the correct module was loaded. Did a cat /proc/scsi/scsi. It gave me

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: PHILIPS Model: CDD3610 CD-R/RW Rev: 3.01
Type: CD-ROM ANSI SCSI revision: 02

Did a dmsg | less. It gave me

scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Vendor: PHILIPS Model: CDD3610 CD-R/RW Rev: 3.01
Type: CD-ROM ANSI SCSI revision: 02

It looks as if every thing is alright !. So what goes wrong ? I'l check up the links you send me. If something turns up, i'l post a another message.

Thanks for helping me,


mrGee 08-25-2002 06:25 AM

i kinda expected that, cause your cdrecord -scanbus seemed to work. How about the mounting thing, did that work or neither?

schatoor 08-26-2002 02:20 PM

No the stupid thing does'nt mount either. I did

mount /dev/sr0 /media/cdrecorder

with a regular cd, but it crashed my system with a kernel panic.

I just follow'd up on the links you send me. It seems like i'l have to re-compile my kernel with NO (!) ATAPI cdrom support and compile a ide-scsi emulation in the kernel instead of loading up emulation with a module. But would'nt this mean that for my cdrom drive to then work, i'l have to load a module ?
If this is right, how do I go about setting things up ? I mean, how do I get a hold on the module that gives me ATAPI support. And were
do I tell the kernel to load the the module.

Would apreciate further help,

Bey, Sohail

MasterC 08-27-2002 07:55 AM

Hi, I have recently rebuilt my kernel again, and accidently left out SCSI support and such, so I have been following this one, until about 2 days ago, when I went back and realized what I had missed in the first recompile.

So, to make a long story short, you can enable both ATAPI CDROM and SCSI Emulation in your kernel build, I do both as built in, no module and those babies.

There is an option in the IDE section of the kernel for scsi emulation, make sure that's checked, then in scsi section, you need scsi cdrom, scsi support, and I also used the one for verbose debugging. If you have questions on any others let us know, I will fire up my config and see what I have marked.

Oh btw, it works like a charm now, and was only down for a total of 3 days while I tried all other options, and finally thought I missed something during the kernel compile.


schatoor 08-27-2002 02:44 PM

Hello there,
Thanks for the advice man. I have just downloaded
the 2.4.19 kernel. He if i'm gonna compile a kernel it might
as well be the new'st version.
I thank all you guy's for the support you have given me.
I just hope I can do something back for linux community
some day.
By the way, do you know of any good kernel compiling howto's
on the web ?

Thanks again, Sohail

mrGee 08-27-2002 02:50 PM

Try this
It's almost to much info
In general is a good place to look.
The suse reference manual might be a good place, if
you got the boxed set, that is.
And do some searches in this forum
good luck

All times are GMT -5. The time now is 09:21 PM.