-   Linux - General (
-   -   CD Record system locks (

drjimstuckinwin 07-11-2001 09:57 AM

CD Record system locks
Finally managed to sort SCSI emulation, and set up my CD-RW drive (HP7200e). CD record -scanbus shows my drive. I setup the DVD drive as SCSI as well so I can burn one to another. When I run xcdroast, all seems to work fine until the actual burn, when I get what seems to be a SCSI communication error. Messages below.

pregap1: -1
Cdrecord 1.9 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jörg Schilling
TOC Type: 1 = CD-ROM
scsidev: '0,1,0'
scsibus: 0 target: 1 lun: 0
Linux sg driver version: 3.1.17
Using libscg version 'schily-0.1'
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 1
Vendor_info : 'HP '
Identifikation : 'CD-Writer+ 7200 '
Revision : '3.01'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags : SWABAUDIO
FIFO size : 16777216 = 16384 KB
Track 01: data 261 MB padsize: 30 KB
Total size: 300 MB (29:47.66) = 134075 sectors
Lout start: 301 MB (29:49/50) = 134075 sectors
Current Secsize: 2048
ATIP start of lead in: -11640 (97:26/60)
ATIP start of lead out: 337350 (75:00/00)
Disk type: Long strategy type (Cyanine, AZO or similar)
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Blocks total: 337350 Blocks current: 337350 Blocks remaining: 203275
RBlocks total: 349030 RBlocks current: 349030 RBlocks remaining: 214955
Starting to write CD/DVD at speed 2 in write mode for single session.
Waiting for reader process to fill input buffer ...
input buffer ready.
cdrecord: Input/output error. mode select g1: scsi sendcmd: retryable error
CDB: 55 10 00 00 00 00 00 00 3C 00
status: 0x0 (GOOD STATUS)
cmd finished after 0.024s timeout 200s
cdrecord: Warning: using default CD write parameter data.
cdrecord: Cannot open new session.
Mode Select Data 00 10 00 00 05 32 02 00 00 00 00 00 00 00 00 00 00 00 00 96 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
cdrecord: fifo had 255 puts and 0 gets.

I tried changing from disc at once to track at once, but this locked up the system, and thus led to me using the power switch to shutdown. Not ideal!

Does anyone have any experience with xcdroast, or any idea what I've done wrong?


drjimstuckinwin 07-13-2001 12:28 PM


unSpawn 07-14-2001 07:16 AM

Uh. havent found an answer, but heres some things to try, works for some ppl, YMMV:
-Newer kernel (if 2.2.18 or lower)
-get newer (latest/stable)cdrecord
-dummy burn a few times before burning
-make iso first, then burn
-miminize system load, get off the LAN, close Xwindows, close any app u dont need, then burn using cdrecord
-disable swap (swapoff -a)
-make it a master w/o any devices as slave
-try a different brand of cdr(w) disks
try if holds something, look at the bugreports or post a mail to joerg schilly.

Im using a 2.2.18/9 with cdrecord 1.9. My slaved HP8200 r/w's w/o probs. I shut down about everything for burn sessions and I prep the ISO's in advance.

cinnix 07-15-2001 07:48 AM

pardon my post, but I used to have lockup problems and bad burns when trying make CD's under windows. :( I shut down the few things that I could which seemed to make the problem less frequent but when I started buring at a slower speed, the problem disappeared.

drjimstuckinwin 07-16-2001 06:39 AM

Tought I'd replied, but clearly it got lost!
I emailed Thomas Niederreiter the XCDRoast guy, who told me it was because I was trying to use disc at once, and the burner doesn't like it. He says to use track at once, and all will be OK. I'm off to give it a go. Apparently it's in his FAQ section, but I didn't see it. Am checking!
Cinnix- I had the same under Win98, but shutting down other stuff didn't always help. I think part of the problem may be that CDRW is comparatively new, and the burners are sensitive. The CDrecord site points out that the burner can't relocate its heads if data stream gets interrupted, so I guess that ANY hard/software problem will stuff a burn up. Fast processors and SCSI all round I guess.

All times are GMT -5. The time now is 10:34 PM.