-   Linux - General (
-   -   Can't su into root as normal user (

darin3200 04-25-2004 06:56 PM

Can't su into root as normal user
I added a normal user when I first installed Gentoo and I was always able to su to get root access. But recently I have been unable to get root access using su. I have checked my /etc/group and I am in wheel.
Any ideas on how to fix this

SciYro 04-25-2004 07:46 PM

is su in /sbin or /bin?

darin3200 04-25-2004 07:52 PM


quatsch 04-25-2004 08:17 PM

what actually happens when you use the
command? any error messages?

darin3200 04-25-2004 08:39 PM

I type in my root password and I get


su: Authentication failure

quatsch 04-25-2004 11:38 PM

can you log in as root at all? Say from a text terminal.

Robert0380 04-26-2004 12:13 AM


darin3200 04-26-2004 08:37 AM


Originally posted by quatsch
can you log in as root at all? Say from a text terminal.
Yeh, i can log out of my user account and then log in as root, but not su from the user account.

quatsch 04-26-2004 12:26 PM

I found this:
seems like it's the same problem and has something to do with

zorba4 04-26-2004 02:53 PM

In AIX there is an option when creating a user : "user can su" (yes or not), and "another user can asu to this user" (yes or not).
Is there such an option in Linux ?

darin3200 04-27-2004 09:04 PM


Originally posted by quatsch
I found this:
seems like it's the same problem and has something to do with

I checked the /etc/pam.d/su file and I don't have the line give by the person the debain mailing list

Nishtya 04-28-2004 03:07 AM

Admittedly know nothing of Gentoo and am newbie, but are you using KDE? Have you recently upgraded to 3.2.2? There is a known bug:
Perhaps related?

darin3200 06-10-2004 03:54 PM

Sorry for the seriously late reply, I had the problem before kde was installed, I have the following

auth      required        /lib/security/
# If you want to restrict users begin allowed to su even more,
# create /etc/security/suauth.allow (or to that matter) that is only
# writable by root, and add users that are allowed to su to that
# file, one per line.
#auth      required    /lib/security/ item=ruser sense=allow onerr=fail file=/etc/security/suauth.allow

# Uncomment this to allow users in the wheel group to su without
# entering a passwd.
#auth      sufficient  /lib/security/ use_uid trust

# Alternatively to above, you can implement a list of users that do
# not need to supply a passwd with a list.
#auth      sufficient  /lib/security/ item=ruser sense=allow onerr=fail file=/etc/security/suauth.nopass

# Comment this to allow any user, even those not in the 'wheel'
# group to su
auth      required    /lib/security/ use_uid nullok

auth      required        /lib/security/ service=system-auth nullok

account    required        /lib/security/ service=system-auth nullok

password  required        /lib/security/ service=system-auth nullok

session    required        /lib/security/ service=system-auth nullok
session    optional        /lib/security/

I have also tried adding the line

auth      required    /lib/security/ nullock
but this prompts me for the password twice and gives the same error

geekgirl16 03-18-2010 12:03 PM

another solution
I found this post while searching for a solution to the same problem. My circumstances were a little different and the solution that worked for me may be relevant to someone else.

My OS is CentOS 5.4 in a production environment with several users who have access to the server for development so adding users to the wheel group in /etc/group is not an ideal solution. We like to try to keep our install as standard as possible across all servers. To that end, here is what I did to troubleshoot

checked permissions on /bin/su. They should be set as setuid...rwsr-xr-x. To make them this way, run chmod u+s /bin/su.

If that works then cat or vi the /etc/pam.d/su file. When I compared this file on the system that didn't work with one that did, I found that the working system had the following line:

#auth required use_uid

On the server that didn't work, this line was there but it was not commented out. Changing it to comment it out fixed the issue for me.

All times are GMT -5. The time now is 10:55 PM.