-   Linux - General (
-   -   Can't play simultaneous sounds in Xandros 3.0 (

Ekim8587 02-23-2005 11:02 AM

Can't play simultaneous sounds in Xandros 3.0
Hi there. I'm unable to play two sounds at once in Xandros 3.0. I can play one MP3 in xmms and one in another media player at the same time and i hear them both. However, should I be listening to an MP3 and try to hear an alert from Gaim, I don't hear the gaim sound. Someone said to modify my asound.conf file, and when I did I received an error when setting my sound system to Autodetect or ALSA in the control center, and I would only be able to hear gaim sounds, and NOT my MP3s at all! Anyone have any ideas?

oneandoneis2 02-23-2005 11:29 AM

You have to do two things to make sound shared:

- Modify your asound file (.asoundrc in my case) to tell ALSA to share

- Modify your software settings so they all use ALSA.

My XMMS, for instance, has ALSA, OSS, Disc Writer and eSound as possible outputs. Mplayer has mpegpes, OSS, Alsa, aRts, eSound, SDL, null, and PCM as possible options.

And Gaim is even worse - it needs to be set to "Sound method: Command" and "Sound Command: aplay %s"

So, make sure all your apps are using ALSA, and make sure your asound file is correct. FWIW, mine is:

pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 8192
rate 44100

bindings {
0 0
1 1

sp0 {
ype plug

slave.pcm "dmixer"


pcm.!default {

type plug

slave.pcm "dmixer"


pcm.default {

type plug

slave.pcm "dmixer"


ctl.mixer0 {

type hw

card 0


Ekim8587 02-23-2005 03:23 PM

Okay so miraculously it works now. I made an asound.conf file and I thought that I'd have to go into control center and change it to something else and back to ALSA just so that the setting would take effect and that's when I get an error. I didn't do that, and now it works. I guess I'm still in Windows mode.:newbie:

Thanks! :)

All times are GMT -5. The time now is 01:28 PM.