-   Linux - General (
-   -   Can't mount encrypted USB drive (

letrout 02-08-2006 07:38 PM

Can't mount encrypted USB drive
SuSE 9.2

I just got a USB hard drive for backups, figured I'd encrypt it for safety. I did this through Yast2 partitioner which I assume uses cryptoloop. Backed up 150 GB, unmounted the drive, now I have no idea how to remount it. My fstab entry is

/dev/sda1 /mnt/usb1 reiserfs noauto,acl,user_xattr,loop=/dev/loop0,encryption=twofish 0 0

When I try to mount it I get

sudo mount /mnt/usb1
Switching to old S.u.S.E. loop_fish2 compatibility mode.
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

I've read this a few times but I'm still baffled. What do I do now?

letrout 02-08-2006 09:50 PM

Ok fixed it. Somehow the wrong algorithm got put into fstab, changed it to

/dev/sda1 /mnt/usb1 reiserfs noauto,acl,user_xattr,loop=/dev/loop0,encryption=twofish256 0 0

and it works now.

All times are GMT -5. The time now is 11:04 PM.