-   Linux - General (
-   -   Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q (

kornerr 05-08-2005 03:07 PM

Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q
Everytime I run "./configure" in glibmm dir I get the following:

. . .
checking for pkg-config... /usr/bin/pkg-config
checking for sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0 gmodule-2.0 >= 2.6.0... Package sigc++-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `sigc++-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sigc++-2.0' found

configure: error: Library requirements (sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.6.0 gobject-2.0 >= 2.6.0 gmodule-2.0 >= 2.6.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

After I

where "sigc++-2.0.pc" is placed, I get the same error message.
Can anyone help me? I'm really at a loss.

PS: "config.log" is available here

Komakino 05-08-2005 04:00 PM

I seem to remember I had similar difficulty. I think I solved it by installing sigc++ into /usr/lib instead of /usr/local/lib

kornerr 05-09-2005 12:51 AM

Thanks, Komakino! That was the problem.

kornerr 05-10-2005 06:09 AM

GParted works perfect!

Komakino 05-10-2005 02:32 PM


Originally posted by kornerr
GParted works perfect!
I thought your name looked familiar :D

All times are GMT -5. The time now is 08:05 AM.