-   Linux - General (
-   -   can't boot; GPIO problem (

shengchieh 02-19-2013 12:11 AM

can't boot; GPIO problem
I'm bouncing around hoping to find someone who can understand
my problem. My apology if this is the wrong sub-forum. I'm
not sure if the problem is software or hardware.

I recently installed archbang (AB) and was messing around with
pacman. Yesterday when I boot, AB doesn't boot. Instead it
showed a screen with two lines. I suspected pacman installed
an incompatible library or something. Today, I reinstalled
AB and still got two lines (maybe the same thing???) saying

gscema-fsck[80]. /dev/sda1. clean, 193490/798112 files, 1827790/3166224 blocks
7.366059] lpc_ich 0000:00:1f.0 I/O space for GPIO uninitialized

I can't read the top line since it is 1/3 blocked - so 1st
line is my guess.

Is there a fix in the BIOS or at bootup? Or using a liveCD?
I suspect this problem would occur with other distros (?!?).
Something got messed up with the display or something and
an AB reinstall did not help.

Update: I noticed

I tried loading defaults in the BIOS, i.e, in the BIOS, I
choose "Load FailSafe Defaults" and "Load Optimized Defaults".
I still get the same problem.

I understand GPIO means General Purpose Input/Output
but I don't see anything that looks like GPIO in the BIOS.

Can I fix this problem so that the desktop will boot
in the BIOS or bootloader?

Further update: I tried booting a SliTaz liveCD and get
the same problem. This GPIO problem has to fixed.

Thank in advanced for any help.


H_TeXMeX_H 02-19-2013 04:02 AM

I think you should run memtest86+ first. I don't think anything you did could have caused such an error with different distros.

shengchieh 02-19-2013 12:45 PM

I did a memory (memtest8). After 5 or so minutes, the
test passed successfully - no errors.


shengchieh 02-20-2013 10:00 PM

Sorry for the delay in posting my workaround.

I never figured out how to resolve the GPIO problem. Also, somehow, whatever I added via pacman changed the boot order.
After fixing the boot order in the BIOS, I installed another distro. Then I went back and reinstall Archbang. Fortunately,
I didn't lose much work since I just started AB. But I'm sure this would be a headache for someone who has alot to
configure. You can retrieve your old files using a liveCD, but configuring your system takes time.

If someone knows the solution, post it for the next person whom find this post via searching for a solution.


All times are GMT -5. The time now is 04:23 AM.