LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   canoscan n670u device read error (https://www.linuxquestions.org/questions/linux-general-1/canoscan-n670u-device-read-error-124413/)

shellcode 12-09-2003 08:47 PM

canoscan n670u device read error
 
i, im having some problems with using my canon canoscan
n670u on slack 9.1 kernel 2.4.22. im using xsane and the error i get is:

Error during read: Error during device I/O

importantly, xsane *finds* the device but i get that error when
previewing/scanning. the same error i get with scanimage.

also importantly, this scanner did work a few days ago! i did the same thing
with xsane and it was fine!

to me it seems as if everything is ok and yet i get I/O errors (tried as root btw)
scanimage -L finds the scanner sane-find-scanner finds it
and the scanner starts making noises for about a second, then waiting for
a few seconds, and then i get an error. please help. thanks.

shellcode@ph33r:~$ dmesg
.............................................
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:1f.2
PCI: Sharing IRQ 11 with 02:0b.0
PCI: Setting latency timer of device 00:1f.2 to 64
uhci.c: USB UHCI at I/O 0xef80, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
i810_rng hardware driver 0.9.8 loaded
hub.c: new USB device 00:1f.2-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x4a9/0x220d) is not claimed by any active driver.
usb.c: registered new driver usbscanner
scanner.c: USB scanner device (0x04a9/0x220d) now attached to scanner0
scanner.c: 0.4.13:USB Scanner Driver
ident: nic h/w: id=0x800c 1.0.0
ident: pri f/w: id=0x15 1.0.7
ident: sta f/w: id=0x1f 1.3.6
..............................................
shellcode@ph33r:~$ /sbin/lsmod
Module Size Used by Not tainted
snd-pcm-oss 37252 0
snd-mixer-oss 11992 0 [snd-pcm-oss]
scanner 10488 0
i810_rng 2656 0 (unused)
uhci 24496 0 (unused)
usbcore 58400 1 [scanner uhci]
prism2_plx 61020 2
p80211 18456 0 [prism2_plx]
snd-ens1371 11596 0
gameport 1452 0 [snd-ens1371]
snd-pcm 55904 0 [snd-pcm-oss snd-ens1371]
snd-timer 13252 0 [snd-pcm]
snd-page-alloc 6004 0 [snd-pcm]
snd-rawmidi 12512 0 [snd-ens1371]
snd-seq-device 3920 0 [snd-rawmidi]
snd-ac97-codec 37240 0 [snd-ens1371]
snd 27460 0 [snd-pcm-oss snd-mixer-oss snd-ens1371 snd-pcm snd-timer snd-rawmidi snd-seq-device snd-ac97-codec]
soundcore 3332 6 [snd]
pcmcia_core 40032 0
ide-scsi 9424 0
agpgart 39576 0 (unused)

shellcode@ph33r:~$ cat /proc/bus/usb/devices
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 11/900 us ( 1%), #Int= 1, #Iso= 0
D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB UHCI-alt Root Hub
S: SerialNumber=ef80
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms
T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=04a9 ProdID=220d Rev= 1.00
C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=usbscanner
E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=16ms
E: Ad=82(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=03(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

shellcode@ph33r:~$ sane-find-scanner

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9, product=0x220d) at /dev/usb/scanner0
found USB scanner (vendor=0x04a9, product=0x220d) at libusb:001:002
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Scanners connected to the parallel port or other proprietary ports can't be
# detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.

shellcode@ph33r:~$ scanimage -L
device `plustek:/dev/usb/scanner0' is a Canon N670U/N676U/LiDE20 USB flatbed scanner

shellcode@ph33r:~$ cat /etc/sane.d/plustek.conf
.........................
[usb] 0x04a9 0x220d
device /dev/usb/scanner0
.........................

thank's for the help.

Edy 08-16-2004 07:22 AM

i had the same problem with xsane 0.91..
my OS: Suse Linux 9.0
Kernel: 2.4
Scanner: Epson Perfection 1260/Photo

PGPGPG 09-18-2004 02:53 PM

Me too. Exactly the same problem with
Suse Linux 9.0
Kernel 2.4.21-202-athlon
Scanner Canon CanoScan 1240U (Vendor Id: 04a9 Product Id: 220e)

Problem occurred after running YOU (Suse Yast Online Update). Not sure if this accidently was the cause, but no other explanation.

Edy 09-19-2004 01:20 AM

Reboot your system...
it helps to me.


All times are GMT -5. The time now is 04:19 PM.