-   Linux - General (
-   -   Cannot set serial info: Address... in use (

bmike1 07-19-2003 01:23 AM

Cannot set serial info: Address... in use
Hi guys.
I was here at the beginning of the year and then returned to MS because I couldn't get my modem going again. Well I returned and still need to get my modem going (I'm talking to you via windows).
I found a link on this board that took me to
w w which told me to:
"setserial /dev/ttyS? irq# portI/OADDRESS ^fourport ^auto_irq skip_test autoconfig spd_vhi "
which gave the response :
"Cannot set serial info: Address already in use."
How do I free the address?
I have a US Robotics V92
I am running knoppix from the HD

2damncommon 07-20-2003 05:59 PM

Knoppix should have detected your modem. Is it a hardware modem or one of their Winmodems? I am not sure what kind of support their Winmodems have on Linux.
You should just need to set-up wvdial or kppp with your ISP info.

bmike1 07-20-2003 06:17 PM

I know that it is not a WINmodem. It was working under linux before and I bought it to replace a WINmodem (stupid thing cost 80 bucks). I had a guy come over to set it up and he just posted some links in the system(or something like that) and it worked like a charm. I wish I could find him again.

There is something else that I recently discovered; there isn't
a CDRom icon and the floppy icon returns the message, "Unable to run the command specified. The file or directory file:/mnt/floppy does not exhist." After this happened I, being the curious guy I am, opened Konqueror onto /mnt and discovered only hard drive icons.
It appears Knoppix didn't like being installed on a hard drive:-) Then I loaded it from the CD and found out they were not on the original either.

2damncommon 07-20-2003 07:58 PM

With the 80 buck price tag, I am guessing it is one of their internal hardware modems. If it is, 'lspci' should show it.
The links he fooled with were probably making sure that your /dev/modem pointed to the correct /dev/ttyS* device.
If you use the Knoppix CD on bootup rather than your hard drive, are you able to get online after running 'wvdialconf' from the root terminal?

bmike1 07-20-2003 08:35 PM

Nope. wvdialconf returned with:
"usage:wvdialconf <configfile-name> (create/update a wvdial.conf file automatically)"
I then typed in 'configfile-name' and 'wvdial.conf' but it returned file not found

bmike1 07-20-2003 08:44 PM

lspci -v (I typed this in, not cut/paste)
000:0b.0 Serial controller US Robotics/3Com 56K Fax/Modem Model 5610 (rev 01) (prog-if 02 [16550])
Subsystem:USR/3Com= Unknown device 00d3
Flags: medium devsel, IRQ 9
I/O ports at ec00 [size= 8]
Capabilities: <available only to root>

2damncommon 07-20-2003 09:35 PM

I am not sure what to make of the "device not found" in your 'ls pci -v'.
The steps I just took to connect VIA a USR external modem to dialup from a Knoppix 3.1 CD (rather than DSL):
wvdialconf /etc/wvdial.conf
(Should detect your modem for the wvdial program)
jpico /etc/wvdial.conf
(will open the file to edit the phone, user, and pass. CTRL-O, to save; CTRL-X to exit; don't forget to remove the comment character in front of each line)
then type:
(to dial your provider)
It sounds like you understand about using the root shell. This all needs to be done from there. (Kmenu -> KNOPPIX -> Root Shell)
I am replying VIA the Knoppix dialup connection now.
If the above does not work, some further troubleshooting with the hardware is probably called for.

bmike1 07-21-2003 01:40 AM

I typed in your commands and then wvdial and thought I was going to get online. Alas, 'twas a flight of fantasy. It's response was as follows:
--> Modem initialialized.
--> Sending: ATDT <phone number>
--> Waiting for carrier.
The modem then picks up the phone line but will not dial.
Then, after the phone line times out, it hangs up, then reconnects, and then redials.

2damncommon 07-21-2003 02:23 AM


The modem then picks up the phone line but will not dial.
Then, after the phone line times out, it hangs up, then reconnects, and then redials.
Partial sucess. The prelim stuff works OK then.
I am not following the last part. You say it will not dial, but then it hangs up, reconnects and redials?
If it is dialing the number but not connecting, the problem is either with the entries in your wvdial.conf or your ISP. May I ask which ISP you are using. I don't believe wvdial can connect to AOL, and I think MSN requires something special in the config, many others work just fine.
Sorry for not asking about your ISP sooner.

bmike1 07-21-2003 09:39 AM

I connect through a company called but that is not the problem. The problem is that it will not dial. It picks up the phone line and after it times out it hangs up the line and then picks the line back up. It keeps doing this until you
a) kill the terminal
b) cntrl-z but wvdial does not work after that
Sorry about the misstatement.

2damncommon 07-21-2003 08:43 PM


The problem is that it will not dial.
That could be bad then. Let me check some more and post what I find, if anything, later. I will take a look at your ISP's site (if I can find it), USR for your model and whatever I can think of on Google and LinuxQuestions.
Your original question may be the right way to do it. The fact that your error message said it was in use made me think it may be more of a configuration thing.

bmike1 07-22-2003 10:09 AM

Well, at least with your method it at least gets to the dial tone.

2damncommon 07-22-2003 07:23 PM

So far I confirm your USR modem should be supported in Linux and your ISP appears to support Linux to some extent.
Here is a link about a similar problem. If you want to try that solution you can see in use IRQs with 'cat /proc/interrupts' in a terminal.
I am going to reboot in Knoppix and watch the wvdial sequence again.

In your wvdial sequence above:

--> Modem initialialized.
--> Sending: ATDT <phone number>
--> Waiting for carrier.
it looks like your modem is failing before actually dialing the number. The next message after the waiting for carrier should be the ATDT<phonenumber> again, then --> Carrier detected. Waiting for prompt.
Confirm hardware connection is correct (phone lines in correct spots), confirm wvdial.conf is correct (it probably is or you would not have got as far as you did),
When you do the 'wvdialconf /etv/wvdial.conf' a part of the output will display the /dev/ttyS* that your modem is found on.
Do 'ls -la /dev/modem'. If that is different, that is part of the problem.
The line in the link above; 'ln /dev/ttyS* /dev/modem' would be they way to set the /dev/modem link to the correct actual device.
The setserial line; 'setserial /dev/ttyS* irq *' would be the way to assign an IRQ if needed.
You shouldn't need to be doing all this with a hardware modem, but possibly because it is a PCI card as the link mentions.

bmike1 07-22-2003 11:38 PM

I really appreciate you helping me out with this challenging problem. To allieve the suspicia of the modem or the ISP being linux uncompatible I did have it running under Linux about 7 months ago. Unforyunately, I can't get ahold of the guy who set it up originally.
This is the redponse I'm currently getting.
--> Initializing modem.
--> Sending ATZ
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
--> Modem initialized
-->Sending ATDT (ISPs #)
<hear dial tone>
<doesn't dial>

I followed your link and looked in that forumn for a solution. I followed the directions here <> (ignoring the MAKEDEV <is already there>) setting everything to ttyS4 and to my IRQ & I/O #s. I'll try this out and get back to you.

bmike1 07-23-2003 12:20 AM

Well, that new advise didn't do anything.... same response. Arghhh! This is so agravting!

All times are GMT -5. The time now is 04:20 PM.