LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-30-2019, 09:16 AM   #1
+lorenzo90+
LQ Newbie
 
Registered: Dec 2014
Posts: 10

Rep: Reputation: Disabled
Cannot send mail with exim4 to gmail


Hi,
I recently had some issues with sending emails with exim4 (mutt or mail commands) to gmail accounts. This is the error log I get when trying:

"This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

lorenzo.cozzi1@gmail.com
host gmail-smtp-in.l.google.com [2a00:1450:400c:c09::1b]
SMTP error from remote mail server after pipelined end of data:
550-5.7.1 [2001:760:2c05:1019:2d8:61ff:fe2e:adc3] Our system has detected that
550-5.7.1 this message does not meet IPv6 sending guidelines regarding PTR
550-5.7.1 records and authentication. Please review
550-5.7.1 https://support.google.com/mail/?p=IPv6AuthError for more information
550 5.7.1 . e8si26543251wrj.94 - gsmtp"

Someone knows how to fix it?

My computer has Debian testing installed with kernel 4.20.0-trunk-amd64.

Thanks in advance,
Lorenzo
 
Old 04-30-2019, 09:50 AM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,830
Blog Entries: 15

Rep: Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668
They give you a link that talks about it. Did you review what is at that link?

In short, many organizations reject email that comes from an address that doesn't have a specific reverse IP "PTR" record in DNS. When I check here and at DNS Stuff it says you have no record for the IPv6 address, 2001:760:2c05:1019:2d8:61ff:fe2e:adc3, listed in the error output.

The DNS Stuff lookup can be done at:
https://tools.dnsstuff.com/#reverseD...61ff:fe2e:adc3

Another link with same error and discussion on how to fix:
https://support.plesk.com/hc/en-us/a...ng-PTR-records
 
Old 04-30-2019, 10:38 AM   #3
+lorenzo90+
LQ Newbie
 
Registered: Dec 2014
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by MensaWater View Post
They give you a link that talks about it. Did you review what is at that link?

In short, many organizations reject email that comes from an address that doesn't have a specific reverse IP "PTR" record in DNS. When I check here and at DNS Stuff it says you have no record for the IPv6 address, 2001:760:2c05:1019:2d8:61ff:fe2e:adc3, listed in the error output.

The DNS Stuff lookup can be done at:
https://tools.dnsstuff.com/#reverseD...61ff:fe2e:adc3

Another link with same error and discussion on how to fix:
https://support.plesk.com/hc/en-us/a...ng-PTR-records
I tried but I couldn't manage to solve the issue. Disabling ipv6 in exim4 would solve the problem, but simply adding 'disable_ipv6 = true' to its config file and restarting the service didn't work. Do you have any clue about how to correctly do it?
 
Old 04-30-2019, 12:28 PM   #4
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,830
Blog Entries: 15

Rep: Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668Reputation: 1668
I don't use Exim myself. This link suggests there should be no spaces so it should be:
Code:
disable_ipv6=true
You appear to have put spaces before and after the equal sign.

Did you run the netstat command listed in above link to be sure it isn't LISTENing on IPv6 after the restart?

Note that you might still run into the rejection when using IPv4 if you have no PTR for your outbound IPv4 IP. Did the message from Gmail change after you restarted?
 
1 members found this post helpful.
Old 04-30-2019, 12:39 PM   #5
+lorenzo90+
LQ Newbie
 
Registered: Dec 2014
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by MensaWater View Post
I don't use Exim myself. This link suggests there should be no spaces so it should be:
Code:
disable_ipv6=true
You appear to have put spaces before and after the equal sign.

Did you run the netstat command listed in above link to be sure it isn't LISTENing on IPv6 after the restart?

Note that you might still run into the rejection when using IPv4 if you have no PTR for your outbound IPv4 IP. Did the message from Gmail change after you restarted?
I tried what suggested in the link you provided and added the string:
Code:
disable_ipv6=true
in the exim4.conf.template file stored in root@host:/etc/exim4 folder.
Now the ipv6 is disabled and I managed to send emails to my gmail address.

Thanks a lot for the help!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] howto: exim4, update-exim4.conf, dc_relay_nets mutiple ipadresses engelienart Linux - Server 2 10-21-2011 02:09 AM
exim4 / portmap compromised. problem "solved" -> exim4 question & rkhunter log eichenhain Linux - Security 2 01-10-2011 11:00 AM
[exim4] how to send mail to local computers (on LAN) jabka Linux - Server 4 05-20-2008 12:26 AM
Postfix : mail cannot send to send outside ( can send/receive locally) bobbinsupport Linux - Networking 3 12-15-2007 10:40 PM
exim4 exim4, setup debian tongueroo Linux - Networking 1 11-09-2004 04:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration