-   Linux - General (
-   -   Cannot send mail due to exim log file permission (

zahoo 02-25-2005 02:07 PM

Cannot send mail due to exim log file permission

I got exim now for more than two years running on my server without any problem. But last week when I updated my packages (I'm using Debian unstable) something could happen.
I just realised that I cannot send mail via pine and it keeps giving an error message without any comment just a bunch of numbers and letters.
I checked around the exim and mail log files and I found this:

"2-22 06:28:29 1D3SXd-0003i1-00 Cannot open main log file "/var/log/exim/mainlog": Permission denied: euid=8 egid=8
Feb 22 06:28:29 iguana exim[14261]: exim: could not open panic log - aborting: original error above"

So I checked the permissions of the /var/log/exim/mainlog file and I found it to be set "root" as owner. So I changed it to be "mail" the owner and left anything else unchanged and this way I could send mails again.

I thought I solved the problem the only thing I didn't understand what did change the owner of the file. BUT the next they it all started again... Cannot send mail... The owner of mainlog was the root again. I played this game for three days so I got no idea what's going on.

Any suggestion?


redgren 11-02-2005 08:58 PM

I know this is pretty old, but did you ever figure this out? I just hit this issue and fixed it the same way, but have no idea how it was working for the past 2 years and all of sudden stopped working.




ahedler 11-02-2005 10:48 PM

We ran across something at work on some SuSE boxes where there's a process that checks certain files/dirs against a config file, and changes permissions back to match the config file if they'd changed. I don't know if that includes ownership, but it could. I'm sorry I can't remember what the process was or the name of the config file, but hopefully this will give you something to start with.


redgren 11-03-2005 11:42 AM

Thanks.. I'll look into that...

All times are GMT -5. The time now is 01:13 PM.