-   Linux - General (
-   -   Cannot login anymore all of a sudden... (

Worstje 07-03-2004 08:09 PM

Cannot login anymore all of a sudden...
Hello all,

I have a pretty good working Slackware-current system.. well HAD a good working system. Right now I cannot figure out what is wrong. Yesterday all of my system was still working fine. Today it isn't... I cannot login as root (not at console, the 60s timeout thingy, nor in ssh). Normal users are 'picky': my own account took me like 5 tries before I got through the barriers of console and ssh. Root is 100% blocked tho :(

I already checked all the things I could think of but I ran out of ideas. As a last resort, I rebooted but it gave me no login chances still :(.

Things I did in the last few weeks (I don't turn it off, linux is made to stay up :D) since it might be many of these... latest first:

- Forgot to write away router logs before, enabled it in syslogd. Changed the switch to -r in one of the bootup files, changed the syslogd.conf and everything worked fine.
--> Just checked if /var partition was full... none of the partitions are. All have atleast 100M free.
- Changed root password. I do this once in a while, only difference with normally is that I read that longer passwords are better. So I changed a 6 letter one to a 13 letters one.
--> Tried logging in with caps lock on (well... might have changed it with capslock on.. ;)), various typo's I know that I make occasionally.. but no luck. Even worse, ssh locked my ip/mac or whatever it is, out right now :|
- About a week ago, I carefully replaced all current rc.* files so that they are up to date. I ofcourse have backups. Never rebooted then, since there was no need and chance at the time.
--> They were not used before the reboot I think, so I don't believe they are the problem. Bootmessages seemed fine today...

ps | aux before the reboot showed many smbd and sshd processes, the last were Z zombified... Hence I rebooted, only way I could solve that problem without root...

I hope anyone can help me, even though my system can still do what I expect of it without my seat , I would like the driverseat back so I can drive with raw penguinpower ;)

Thanks for reading everyone :)

320mb 07-04-2004 11:17 AM


- About a week ago, I carefully replaced all current rc.* files so that they are up to date. I ofcourse have backups. Never rebooted then, since there was no need and chance at the time.
you may have changed the permissions of some/all of the "rc" files and the
system may not be able to read from them to start system services........

just a thought.......

<edit/> some of those "rc" files are $SHELL SCRIPTS and need to be
executable for some of the system services to start up.........

Worstje 07-04-2004 12:31 PM

For as far I can see all the rc.* files I need are marked with a * (executable).
Here is the ls output: (once again, am using Slackware, so unused scripts are usually marked by not-executable)


lrwxr-xr-x  1 root root    4 Jun 22 18:52 rc.0 -> rc.6*
-rwxr-xr-x  1 root root  893 Jan 29  2003 rc.4*
-rwxr-xr-x  1 root root  5303 Jun 21 18:32 rc.6*
-rwxr-xr-x  1 root root  4782 Sep 12  2003 rc.6.old*
-rwxr-xr-x  1 root root  1989 Jun 21 16:04 rc.K*
-rwxr-xr-x  1 root root  2013 Feb 27  2003 rc.K.old*
-rwxr-xr-x  1 root root  7906 Jun 20 05:42 rc.M*
-rwxr-xr-x  1 root root  7634 Sep 15  2003 rc.M.old*
-rwxr-xr-x  1 root root 10324 Jun 20 06:26 rc.S*
-rwxr-xr-x  1 root root  8312 Aug 28  2003 rc.S.old*
-rwxr-xr-x  1 root root  466 Feb 26 01:10 rc.acpid*
-rw-r--r--  1 root root  1032 Feb  2  2003 rc.atalk
-rw-r--r--  1 root root  1031 Sep 21  2003 rc.bind
-rwxr-xr-x  1 root root  306 Jun  8  2003 rc.bootsplash*
-rw-r--r--  1 root root  3949 Aug 26  2003 rc.cups
-rwxr-xr-x  1 root root  119 May 30 06:19*
-rwxr-xr-x  1 root root  1156 Apr 16 21:37 rc.gpm-sample*
-rwxr-xr-x  1 root root  1511 Jun 21 05:34 rc.hotplug*
-rwxr-xr-x  1 root root  401 Mar  5  2003 rc.httpd*
-rwxr-xr-x  1 root root  5774 Jun  7 08:42 rc.inet1*
-rw-r--r--  1 root root  899 Apr 16 19:59 rc.inet1.conf
-rw-r--r--  1 root root  862 Aug 27  2003
-rwxr-xr-x  1 root root  4038 Sep 21  2003 rc.inet1.old*
-rwxr-xr-x  1 root root  4583 Jun  7 08:08 rc.inet2*
-rwxr-xr-x  1 root root  4419 Sep 21  2003 rc.inet2.old*
-rwxr-xr-x  1 root root  497 Sep 12  2003 rc.inetd*
-rw-r--r--  1 root root  1924 Sep 14  2003 rc.ip_forward
-rwxr-xr-x  1 root root  140 May  5 13:17 rc.local*
-rwxr-xr-x  1 root root  113 Oct  3  1995*
-rw-r--r--  1 root root  580 Sep 12  2003 rc.lprng
-rwxr-xr-x  1 root root 25455 Jun 14 02:05 rc.modules*
-rw-r--r--  1 root root 25454 Jun 14 02:05 rc.modules.backup
-rwxr-xr-x  1 root root  2259 Sep 19  2003 rc.mysqld*
-rwxr-xr-x  1 root root  2389 Jun  6 23:52 rc.nfsd*
-rw-r--r--  1 root root  4790 Apr 13 00:37 rc.pcmcia
-rw-r--r--  1 root root  905 Sep 14  2003 rc.portmap
-rw-r--r--  1 root root  728 Apr  7  2003 rc.samba
-rw-r--r--  1 root root  687 Jun  4  2002 rc.sendmail
-rwxr-xr-x  1 root root  2895 May 27 23:25 rc.serial*
-rwxr-xr-x  1 root root  1222 Feb 25 07:43 rc.sshd*
-rwxr-xr-x  1 root root  866 Jul  1 23:22 rc.syslog*
-rwxr-xr-x  1 root root  861 May 29  2002 rc.syslog.old*
-rwxr-xr-x  1 root root  1740 Sep 11  1999 rc.sysvinit*
-rwxr-xr-x  1 root root  1396 Jun 14 08:59 rc.udev*
-rwxr-xr-x  1 root root  1823 May 17 02:18 rc.udev.old*
-rwxr-xr-x  1 root root  2323 Sep 22  2003 rc.yp*

Also my dmesg (hadn't occured to me that I had access to that as a normal user before)...


Linux version 2.6.7 (root@coresausage) (gcc version 3.3.4) #7 Sat Jun 19 18:44:57 CEST 2004
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000008000000 (usable)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
128MB LOWMEM available.
On node 0 totalpages: 32768
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 28672 pages, LIFO batch:7
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.0 present.
ACPI disabled because your bios is from 00 and too old
You can enable it with acpi=force
Built 1 zonelists
Kernel command line: auto BOOT_IMAGE=BSLinux-2.6.7 ro root=303 splash=silent
bootsplash: silent mode.
Initializing CPU#0
PID hash table entries: 1024 (order 10: 8192 bytes)
Detected 735.013 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Memory: 125708k/131072k available (2433k kernel code, 4792k reserved, 889k data, 144k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 1445.88 BogoMIPS
Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU:    After generic identify, caps: 0387f9ff 00000000 00000000 00000000
CPU:    After vendor identify, caps: 0387f9ff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU serial number disabled.
CPU:    After all inits, caps: 0383f9ff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel Pentium III (Coppermine) stepping 03
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
checking if image is isn't (ungzip failed); looks like an initrd
Freeing initrd memory: 56k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfb0a0, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
Linux Plug and Play Support v0.97 (c) Adam Belay
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router VIA [1106/0596] at 0000:00:07.0
vesafb: framebuffer at 0xe6000000, mapped to 0xc8800000, size 3072k
vesafb: mode is 1024x768x16, linelength=2048, pages=0
vesafb: protected mode interface info at c000:0336
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
fb0: VESA VGA frame buffer device
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16ac)
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Installing knfsd (copyright (C) 1996
udf: registering filesystem
Initializing Cryptographic API
Activating ISA DMA hang workarounds.
bootsplash 3.1.4-2004/02/19: looking for picture.... silentjpeg size 24219 bytes, found (1024x768, 33509 bytes, v3).
Console: switching to colour frame buffer device 118x36
lp: driver loaded but no devices found
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing disabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
parport0: PC-style at 0x378 [PCSPP(,...)]
lp0: using parport0 (polling).
Using anticipatory io scheduler
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:07.1
VP_IDE: chipset revision 16
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c596b (rev 23) IDE UDMA66 controller on pci0000:00:07.1
    ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:DMA
hda: ST320423A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 40011300 sectors (20485 MB) w/512KiB Cache, CHS=39693/16/63, UDMA(66)
 hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 hda8 hda9 >
hdc: ATAPI 11X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
libata version 1.02 loaded.
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:07.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
uhci_hcd 0000:00:07.2: irq 10, io base 0000d400
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
NET: Registered protocol family 2
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
ip_conntrack version 2.1 (1024 buckets, 8192 max) - 296 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
ipt_recent v0.3.1: Stephen Frost <>.
arp_tables: (C) 2002 David S. Miller
NET: Registered protocol family 1
NET: Registered protocol family 17
RAMDISK: Couldn't find valid RAM disk image starting at 0.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 144k freed
Adding 498004k swap on /dev/hda2.  Priority:-1 extents:1
EXT3 FS on hda3, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda7, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
ReiserFS: hda8: found reiserfs format "3.6" with standard journal
ReiserFS: hda8: using ordered data mode
ReiserFS: hda8: journal params: device hda8, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda8: checking transaction log (hda8)
ReiserFS: hda8: Using r5 hash to sort names
process `syslogd' is using obsolete setsockopt SO_BSDCOMPAT
PCI: Found IRQ 5 for device 0000:00:12.0
PCI: Sharing IRQ 5 with 0000:00:0c.0
ne2k-pci.c:v1.03 9/22/2003 D. Becker/P. Gortmaker
PCI: Found IRQ 10 for device 0000:00:10.0
eth0: RealTek RTL-8029 found at 0xe000, IRQ 10, 00:20:18:BA:26:5A.
8139too Fast Ethernet driver 0.9.27
PCI: Found IRQ 11 for device 0000:00:0a.0
eth1: RealTek RTL8139 at 0xd800, 00:50:fc:a3:02:1b, IRQ 11
eth1:  Identified 8139 chip type 'RTL-8100B/8139D'

PYREST 07-04-2004 03:43 PM

Maybe you've been entering your password wrong. Did you check to see if you could log back in after you had changed it?

Worstje 07-04-2004 07:23 PM

Yes I checked at the time and it worked. Just seeing that it has been changed succesfully isn't enough... I prefer to be sure.. :)

Well I guess I am going to see if the night brings any suggestions... Thanks all :)

Worstje 07-05-2004 01:22 AM

God knows why... but today everything is working fine again... no reboot anymore since it acted weird... Well problem is away... Thanks all :)

All times are GMT -5. The time now is 11:40 PM.