LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-10-2012, 01:47 AM   #16
gpraju
LQ Newbie
 
Registered: Apr 2012
Posts: 1

Rep: Reputation: Disabled

hi all,
I am basically an Oracle DBA, having little knowledge in Linux. Today i faced a problem in our environment which needs some administrator level knowledge in Linux. This posting helped me and worked for me. I appriciate this forum for helping the people like us.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 04-10-2012, 02:31 AM   #17
yoK0
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware, CentOS
Posts: 29

Rep: Reputation: 0
Run system in single user(recovery) mode.
You need to re-mount filesystem with write-read access.

# mount -o remount,rw / - should do

Change fstab.
Re-mount filesystem with read-only
Reboot
 
Old 06-16-2012, 09:08 AM   #18
Kamina
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /
Saved me too =D

Revived threads: 1
Closed threads: 0
 
Old 12-18-2012, 12:25 PM   #19
jgillaspy
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /
Worth its weight in gold...

Thanks,

JG
 
1 members found this post helpful.
Old 10-11-2013, 07:12 AM   #20
tsilis3
LQ Newbie
 
Registered: Oct 2013
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /

I registered in this forum only to say thanks for this very helpful post!
 
Old 08-23-2014, 01:59 PM   #21
mrdrew
LQ Newbie
 
Registered: Aug 2014
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by tsilis3 View Post
I registered in this forum only to say thanks for this very helpful post!
I second this sentiment. Thanks
 
Old 08-23-2014, 11:52 PM   #22
solarisguy
Member
 
Registered: Aug 2010
Location: Seattle
Distribution: CentOS, RHEL, Oracle Enterprise Linux, Solaris, BSD
Posts: 64

Rep: Reputation: 21
I think it's awesome that 4 years after my original contribution to this thread, that people are still reading and finding it useful. I end up showing this to members of our very large engineering organization every few months. It's surprising how little known this trick is, but it can definitely be a life saver.

Since my original posting, I've become a RedHat Certified Systems Admin (RHCSA) as well as RedHat Certified Engineer (RHCE).

If anyone has any RedHat questions, or need help getting a system running with selinux, post in the forum and send me a PM with the link and I'll be happy to contribute. Since I earned my certifications with RedHat, every system I have built has been configured with selinux enforcing and with the most strict policies possible for the tightest security.

Additionally, even internal systems have firewalls locked down as tightly as possible. If you don't know what the requirements for your applications are, in terms of protocols and ports, you need to focus on learning that piece before going live anyway.
 
Old 08-24-2014, 12:03 AM   #23
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
With VI to enter command you have to put : to enter command mode, so it would be
Quote:
:w
http://www.lagmonster.org/docs/vi.html

Last edited by EDDY1; 08-24-2014 at 12:04 AM.
 
Old 10-11-2015, 12:13 AM   #24
estrivro
LQ Newbie
 
Registered: Oct 2015
Posts: 1

Rep: Reputation: Disabled
Thanks!

Almost 2016 and this just saved me after a frustrating hour spent locked out of my home linux server:
mount -o remount,rw /

Thanks and greetings from Costa Rica!
 
Old 11-17-2015, 03:14 PM   #25
teknopaul
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
remount failed for me

remount failed for me since I had stuffed up the /etc/fstab line for /

Suppling the device and mount point makes mount not read /etc/fstab (I think)

On Ubuntu 15.10 I typed this

mount -t ext4 /dev/sdwhatever / -o remount

and it continued to boot, presumably I fired an upstart even so boot continued.
 
Old 12-15-2015, 02:20 AM   #26
adhamsabry51
LQ Newbie
 
Registered: Dec 2015
Posts: 1

Rep: Reputation: Disabled
Thumbs up

Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /
this never gets old man you saved my day i was facing this problem
 
Old 01-11-2016, 08:11 AM   #27
Back-N-Black
LQ Newbie
 
Registered: Oct 2013
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by GNakul View Post
mount -o remount,rw / is not working for me.4
It says Unrecognized mount option "realtime.acl.errors=remount-ro". I edited that line by mistake. How do i remove it??
I received the same error.
Try this instead: mount / -o remount,rw

It worked nicely on my Centos 6 system. Did not have to edit grub, wait for reboot, etc.
 
Old 02-27-2016, 09:55 AM   #28
gjinchrist
LQ Newbie
 
Registered: Dec 2013
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /
This just helped me after I wiped out a partition and rebooted while studying for the rhcsa. Thanks!
 
Old 03-13-2016, 06:02 PM   #29
dbushong
LQ Newbie
 
Registered: Mar 2016
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /
Now six years later, still helpful. I think you just saved me from a trip to Asia to fix a customer problem.

Thanks solarisguy!
 
Old 02-05-2017, 09:27 AM   #30
penguinbody
LQ Newbie
 
Registered: Jan 2016
Posts: 10

Rep: Reputation: Disabled
Post

Quote:
Originally Posted by solarisguy View Post
I know this thread is old, but I thought I would offer a simpler solution:

mount -o remount,rw /
Thanks this helped me out.

I was editing the /etc/fstab file, to add usrquota to the device. After a reboot the device went to a Read Only state.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edit "read-only" /etc/fstab from "System Recovery#" (without boot cd?) charlweed Linux - General 1 12-31-2006 05:57 PM
wish to edit but fstab is read only obay Linux - Newbie 3 07-29-2006 03:25 PM
cannot edit fstab in SELinux active mode eldraque Fedora 1 01-19-2006 03:38 AM
How do I change "fstab" to Write/Edit Mode? sharathkv Linux - Newbie 4 07-29-2003 07:52 AM
Mounting root filesystem in read only mode. Ocran Linux - Software 3 07-01-2002 12:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration