-   Linux - General (
-   -   Cannot boot ubuntu linux after using gparted on rEFIt iMac (

jeberd 12-23-2008 06:25 PM

Cannot boot ubuntu linux after using gparted on rEFIt iMac
I hope that this is a 'General' topic, but if not delete it, tell me where to go and I will repost there.

I had a working dual boot config with OSX and ubuntu on an iMac (most recent refresh). Everything was fine until I edited a partition using gparted running ubuntu. Now when I boot into rEFIt my linux partition is reported as Legacy OS and if I select it, it gives me an error about not finding the OS and the computer freezes necessitating a hard shutdown.

The configuration that I had was:

part# used for size

1 EFI ~200M
2 OSX ~80G
3 ubuntu ~30G
4 file space (fat32) ~190G
5 linux swap ~2G

what I tried to do was to make another partition using some of the file space (part# 4) that I was going to install a second linux distribution on. Editing of the partition went fine, but after rebooting I cannot get back to my original ubuntu partition. OSX loads just fine. I can use rEFIt to boot live cd's just fine. Only my ubuntu partition is not working, but like I said it knows it is there, just calls it Legacy. I did not change the ubuntu partition at all when I used gparted, I only shrunk the file space to make some free space. I never actually installed another OS because this problem arose and I didn't want to complicate things.

I checked the rEFIt documentation and there was some mention of problems caused by parted []. It didn't seem to explain my situation exactly though and it said that the problems were fixed in ver 0.9. I am using the most recent version, ver. 0.12. Regardless, I checked to make sure that there was not any flags set on the ubuntu partition as it instructed to solve the similar problem and there are none. This same problem happened to me before when I tried to shrink the actual ubuntu partition and the only way I was able to resolve it before was to reinstall ubuntu which caused it to work. I didn't ask for help before though and that was just my solution. I'd prefer not to have to do that... All of my files are fine, I can see them when booting a live cd, I just cannot seem to be able to boot the linux. I think this should be an easy enough fix, I just am not familiar enough to do it on my own. The computer loads rEFIt then rEFIt passes off to GRUB to load ubuntu under normal operation. It never loads GRUB though since the change to Legacy OS from Linux OS.

This is the output from the partition inspector that comes with rEFIt. It says that they are synchronized though they do not even have the same number of partitions. The ones that are listed have the same ending points, so maybe that is what it means by 'synchronized':

*** Report for internal hard disk ***

Current GPT partition table:
# Start LBA End LBA Type
1 40 409639 EFI System (FAT)
2 409640 127599183 Mac OS X HFS+
3 211559985 605538044 Basic Data
4 127604295 211559984 Basic Data
5 616896000 625137344 Linux Swap

Current MBR partition table:
# A Start LBA End LBA Type
1 1 409639 ee EFI Protective
2 409640 127599183 af Mac OS X HFS+
3 * 211559985 605538044 0c FAT32 (LBA)
4 127604295 211559984 83 Linux

MBR contents:
Boot Code: Unknown, but bootable

Partition at LBA 40:
Boot Code: None (Non-system disk message)
File System: FAT32
Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
Boot Code: None
File System: HFS Extended (HFS+)
Listed in GPT as partition 2, type Mac OS X HFS+
Listed in MBR as partition 2, type af Mac OS X HFS+

Partition at LBA 211559985:
Boot Code: None (Non-system disk message)
File System: FAT32
Listed in GPT as partition 3, type Basic Data
Listed in MBR as partition 3, type 0c FAT32 (LBA), active

Partition at LBA 127604295:
Boot Code: None
File System: ext3
Listed in GPT as partition 4, type Basic Data
Listed in MBR as partition 4, type 83 Linux

Partition at LBA 616896000:
Boot Code: None
File System: Unknown
Listed in GPT as partition 5, type Linux Swap

jeberd 12-23-2008 06:37 PM

for some reason all of my extra spaces for formatting are being removed so everything looks squished together. When I select edit for the post the spaces are still there, but when I save they are gone again. Is there a reason for this?

tom4everitt 01-28-2009 03:09 AM

I just wanted to say that I have almost the exact same problem on my macbook. rEFIt just won't find my linux partition anymore (or rather, sees it as a "legacy OS").

I've reinstalled rEFIt, but didn't help much.

I find this entire issue very confusing; I haven't messed with my Linux partition at all, and yet it is suddenly not working. If anyone could help, or just explain what might have gone wrong, it would be much appreciated.

EDIT: Tip in this thread solved the problem, for me at least.

All times are GMT -5. The time now is 08:06 AM.