LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - General (http://www.linuxquestions.org/questions/forumdisplay.php?f=1)
-   -   can not change root password from root (http://www.linuxquestions.org/questions/showthread.php?t=4175449378)

riponnk 02-10-2013 02:39 AM

can not change root password from root
 
Hello ,
I am using CentOS 6.3. I cann't change root password.

Changing password for user root.
New password:
Retype new password:
passwd: Authentication token manipulation error

bathory 02-10-2013 11:08 AM

Hi,

Run:
Code:

pwconv
to re-create the /etc/shadow file

Regards

pingu 02-10-2013 11:10 AM

1) You have tried several times I hope?
If not, just try again - maybe ther was a mismatch between your two passwords.
2) How about password requirements?
AFAIK that is most commonly set with PAM.
Check under /etc/pam.d/ (or whatever GUI-tool there might be for this).
3) Are all accounts local, or do you use an authentication system (AD, LDAP etc)?

riponnk 02-11-2013 07:41 AM

I have tried several times , there's no mismatch with password. Only one local account here .

YankeePride13 02-11-2013 08:25 AM

Is the root filesystem mounted in read only mode by any chance?


All times are GMT -5. The time now is 02:51 AM.