Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 02-28-2007, 11:07 PM   #1
Winter Knight
Registered: Nov 2005
Distribution: Debian Stable/Testing
Posts: 54

Rep: Reputation: 15
Cool [Fixed]: Can't get microphone working in Debian Etch (testing)

Help! I can't get my microphone to record in Debian Etch. It doesn't work with any VOIP providers that I've tried, Skype, Gizmo, or Wengo. When I run sound-recorder, I just get a 4096 byte file (regardless of how long it was recording). When I run arecord, I just get a 44 byte file (regardless of how long it was recording).

I've tested this microphone on the same machine with Ubuntu Dapper Drake LiveCD. It works fine there. In the Ubuntu sound recorder program, I had to use the "capture" device, as "microphone" didn't do it.

It was working with skype last month. I made a few gizmo calls too, even just a few weeks ago. I don't recall having changed any major settings.

I've checked alsamixer. Everything looks good. Microphone not muted, at full power. Also, "playback" seems to work. I can talk into the microphone, and hear my voice out of my speakers, but can't record it, or get skype or gizmo to understand it. Skype is the same version that it has been for quite some time. I've tried gizmo under the version that I was using before, as well as their new, upgraded version. Similar results. Echo tests fail with VOIP software. I can hear the computer, but can't get my voice recorded.

On the advice given to someone else on a different thread, I did this:
ALPHA:/home/wk# dd bs=8k count=6 < /dev/audio >
dd: reading `standard input': Input/output error
0+0 records in
0+0 records out
0 bytes (0 B) copied, 10.0006 seconds, 0.0 kB/s
It just sits there for a few seconds, pretending to record, and gives me those errors. Both as my regular user with audio privileges, and as root.

Thanks in advance for any help given. VOIP is my only phone, except for an unactivated cell phone which only dials 911. Thank you.

UPDATE: Damn obsure settings. Somehow, my mixer setting "Import Source Select" and "Import Source Select 1" both got changed to Input2. I put them back to "Input1" (I guess that is where they were before), and it works now.

In might be interesting to note how I discovered this. I enabled, maximized and/or switched everything in alsamixer. That made it work! Then, two by two, I put things back how they were, until it failed again.

But before that, I updated and recompiled my alsa modules for nothing.

Last edited by Winter Knight; 03-01-2007 at 12:31 AM.
Old 03-01-2007, 06:14 AM   #2
Registered: Dec 2005
Location: Tväråmark, Sweden
Distribution: Debian/Kubuntu
Posts: 100

Rep: Reputation: 16
Good example!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems getting intel bg2200 working on debian etch precision Linux - Wireless Networking 2 04-06-2007 05:08 PM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 10:02 PM
No Sound on Intel 915G in Debian etch 4.0(testing) fandango512 Linux - Hardware 2 11-17-2006 03:08 PM
debian testing etch not finding all my RAM LaoNiu Linux - Laptop and Netbook 2 05-14-2006 08:36 AM
Sarge-testing To Etch-testing? SMurf7 Debian 3 02-21-2006 10:59 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:59 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration