LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-18-2003, 12:25 PM   #1
Odan
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Distribution: Try to learn about SuSE Mandrake Debian(Knoppix)
Posts: 24

Rep: Reputation: 15
Unhappy canīt enable DMA-Mode why?


Hello,

I have SuSE 8.1 with KDE 3.1.something ;-) running.
When I try to enable DMA-Mode with Systemadministration by YaST for either the harddisks and the DVD-Rom. Yast tells me "error - couldnīt set device hda (and hdc and hdd; everyone after another) to value `1ī. And so when i start yast again i see the current state is all of them are DMA-disabled.

Is there another way or what could it be?

I have also an SuSE 8.1 one withe the original KDE 3.0 running and it does not function either.

Thanks a lot

Odan
 
Old 10-18-2003, 05:35 PM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
from the c0ommand line
as root

hdparm -d1 /dev/hda

this is the command to enable dma
if it responds ok

(under mandrake and redhat)
i add that line to the end of /etc/rc.local

(i also add -c1 (to switch 32bit support on) and -k1 (tells it to keep settings after a reset))
 
Old 10-19-2003, 02:07 PM   #3
Odan
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Distribution: Try to learn about SuSE Mandrake Debian(Knoppix)
Posts: 24

Original Poster
Rep: Reputation: 15
hdparm

Thanks,

but hdparm does not work either.
it just tells thatit canīt set hda with DMA on.

Could there be another way or a bios thing or something

Thanks

Odan
 
Old 10-19-2003, 02:35 PM   #4
Mad Merlin
Member
 
Registered: Aug 2003
Location: Approximately here.
Distribution: Mandrake 9.1
Posts: 86

Rep: Reputation: 15
If you've got bleeding edge hardware or a bleeding edge motherboard, you'll probably need a newer kernel to support the hardware. I'd give that a try first.
 
Old 10-19-2003, 02:38 PM   #5
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
I know when I was using Slackware 9 with the default kernel 2.4.20 I couldn't get proper hard drive settings to work either. I was getting 3mb/s disk reads. Compiled 2.4.22, did hdparm, and got 40mb/s disk reads.
 
Old 10-19-2003, 07:18 PM   #6
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Yeah, you need to have ultra-dma enabled in the kernel, I had this problem too.

First thing to check -- Is 32 bit LBA operation enabled?

see if this works:

hdparm -c1 /dev/hda

That'll switch it 32 (i know it's already mentioned above, but I wanted to stress it.)

IF that goes through, then try

hdparm -d1 /dev/hda

IF neither go through, you'll need to recompile your kernel with dma support.

-Shade
 
Old 10-19-2003, 10:25 PM   #7
h1tman
Member
 
Registered: Jul 2003
Distribution: Slackware 11
Posts: 439

Rep: Reputation: 30
root@darkstar:/home/h1tman# hdparm -c1 /dev/hda

/dev/hda:
setting 32-bit IO_support flag to 1
IO_support = 1 (32-bit)
root@darkstar:/home/h1tman# hdparm -d1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
root@darkstar:/home/h1tman#
 
Old 10-20-2003, 12:50 AM   #8
Odan
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Distribution: Try to learn about SuSE Mandrake Debian(Knoppix)
Posts: 24

Original Poster
Rep: Reputation: 15
compiling

Hi guys,

i get the same with hdparm as "h1tman" does. So, how do i compile the kernel?

Thanks

Odan
 
Old 10-21-2003, 05:01 PM   #9
Odan
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Distribution: Try to learn about SuSE Mandrake Debian(Knoppix)
Posts: 24

Original Poster
Rep: Reputation: 15
Please,

how do i recompile the kernel with DMA support?

Thanks

Odan
 
Old 10-21-2003, 06:57 PM   #10
nrunge
Member
 
Registered: Oct 2003
Distribution: Debian Woody (2.4.22)
Posts: 182

Rep: Reputation: 30
I am having the same problem. However DMA is compiled into my kernel, and I am running 2.4.22.

Please refer to >http://www.linuxquestions.org/questi...hreadid=104957

For more of my system information.
 
Old 10-22-2003, 02:11 AM   #11
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
slackware 9 has dma support
i've installed it and used it before and hdparm worked first time

is it worth checking the BIOS to see if DMA is turned off?
 
Old 10-22-2003, 07:45 AM   #12
Odan
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Distribution: Try to learn about SuSE Mandrake Debian(Knoppix)
Posts: 24

Original Poster
Rep: Reputation: 15
Well, DMA is enabled by the BIOS and e.g. Windows is using the DMA-Mode.
So how do i figure out my kernel and get a DMA Support compiled, sorry, but i just donīt know.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't enable DMA Timeturtle Linux - Hardware 9 06-03-2004 06:34 PM
Enable DMA ust Linux - General 1 02-09-2004 02:28 AM
Suse 8.2 change my DMA setting on my DVD-R drive to off & IDE DMA MODE NOT SHOWING IT maximalred Linux - General 0 08-23-2003 05:58 AM
How to enable DMA? Piero Linux - Hardware 14 07-21-2003 07:05 AM
enable DMA? Alinuxnoob Linux - Newbie 1 02-28-2002 04:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration