LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-30-2003, 09:48 PM   #1
Al Bundy
LQ Newbie
 
Registered: Mar 2003
Location: Perth Australia
Posts: 17

Rep: Reputation: 0
Unhappy Canít hear sound after running Sound Config


Hello

I have a problem with my sound configuration (cant hear any sound). I was searching for solutions and found the sound configuration utility, ran that and it suggested I disable PnP in the BIOS so I did that. The sound card was then configured, but I still cannot hear a test sound. My speakers are plugged in as normal.

My motherboard is a Asus P4PE, its specifications say it has a ADI AD1980 AC 97 CODEC on board

Any suggestions.

Here are some pictures of the Sound config program
and my sound card





Another question, is there a way to search for past commands I have made in the shell rather that pressing the up arrow until you find the one you want?

Thanks for any help

 
Old 03-30-2003, 09:55 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
Quote:
Another question, is there a way to search for past commands I have made in the shell rather that pressing the up arrow until you find the one you want?
<Ctrl+R>/<S> (reverse <search>, if you're in bash, that is)


Cheers,
Tink
 
Old 03-30-2003, 09:59 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
Btw ... as for the sound: what distro are you using? :)

And did soundconfig complete without errors?


Cheers,
Tink
 
Old 03-30-2003, 10:10 PM   #4
Al Bundy
LQ Newbie
 
Registered: Mar 2003
Location: Perth Australia
Posts: 17

Original Poster
Rep: Reputation: 0
I first compiled an old verson, and got some errors then got a newer verson and that compiled ok, its verson .69


 
Old 03-30-2003, 11:16 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
What's the output of
lsmod
as root?
If the modules are loaded,
did you run some mixer app
and check it's not just muted
or on volume level 0?

Cheers,
Tink
 
Old 03-31-2003, 05:27 AM   #6
drphibes
Member
 
Registered: Mar 2003
Posts: 34

Rep: Reputation: 15
I have yet to hear from a P4PE user who has NOT had to use alsa to get his/her sound working. I posted a little while ago on how to get it running. See this thread:

http://www.linuxquestions.org/questi...threadid=50826

drphibes
 
Old 04-01-2003, 12:05 AM   #7
Al Bundy
LQ Newbie
 
Registered: Mar 2003
Location: Perth Australia
Posts: 17

Original Poster
Rep: Reputation: 0
I pretty new to the whole Linux environmentÖ.. I got some errors when I installed alsa. I bunziped it to a directory in my home area and then ran tar -xf thfilename.extention (I first tried tar Ėzxf but was getting errors regarding not gunzip format) and than ran ./configure then make and at this point I was getting some errors like (certain) directorys none existant. So the installation aborts.

When I run configure should I specify a location for the installation and if so what location would be suitable.

Tinkster Ill see what the output of lsmod is when I run it when I get home.. I've been searching around for some volume controls and playing with settings by have had no luck.

Thanks for all the help
 
Old 04-01-2003, 05:31 PM   #8
drphibes
Member
 
Registered: Mar 2003
Posts: 34

Rep: Reputation: 15
First read the documentation at www.alsa-project.org . There is extensive information on what to do, including step-by-step for new users.
Also, study up on kernel modules, what they are and how to configure them, i.e. how to use the modules.conf file, modprobe, etc.

drphibes
 
Old 04-01-2003, 09:10 PM   #9
Al Bundy
LQ Newbie
 
Registered: Mar 2003
Location: Perth Australia
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks for your guidance I am really new to this environment so any help is appreciated, I will read the docs and look into kernel modules (whatever the hell they are), it will all eventually fall into place.
 
Old 06-26-2003, 09:09 AM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Rep: Reputation: 128Reputation: 128
Try something simple. I have the P4PE. The sound was configured correct, but I found that you have to plug your speaker jack into the pink (microphone) jack for it to work with RH9, versus the green (line out) jack for Windoze.

I hosed my system and reinstalled, not knowing how to fix it. Now I can't get sound - it says the soundcard is disabled. So I will read your posts more thoroughly and see if I find the answer. I can't even find redhat-config-soundcard.

Hope this helps - when someone had helped me configure mine before I had to change the jack to get sound, then it worked great.
 
Old 07-04-2003, 04:19 AM   #11
duncang
LQ Newbie
 
Registered: Jul 2003
Posts: 9

Rep: Reputation: 0
Angry

I have just installed Red Hat 9 and have problems with the soundcard on an ASUS P2XP=X motherboard - also an AD1980 chip.
The default install installed an i810_audio driver which seems to work OK if you plug the speaker into the microphone plug. Reading the motherboard manual it seems this plug provides output to the Front Speaker when using surround sound mode - so I guess there is a problem with the driver.

Fiddling around I did eventually get the intel8x0 driver to load - but there seem to be two on the disk - ot sure which is being loaded. Anyway no sound at all even after using alsamixer and others...
 
Old 07-04-2003, 05:05 AM   #12
duncang
LQ Newbie
 
Registered: Jul 2003
Posts: 9

Rep: Reputation: 0
I just found the solution - had all the same problems described about and installed the ALSA drivers(0.9.4) - find them on the alsa.org site. Be careful when installing - not quite sure but I had to manually remove the default driver installed by the OS (i810_audio). And then run the alsamixer program - DONT JUST INCREASE THE VOLUME - BE SURE TO CLICK 'M' for Mute to turn MUTE OFF. Everything OK now and sound is coming from the right place not the Mic jack. Recording is also working correctly now. Seems other players also working OK now. Send me an email if you need further help !!
 
Old 07-05-2003, 06:21 AM   #13
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Rep: Reputation: 128Reputation: 128
Just left www.alsa-project.org

Read everything there, and determined that if *alsa* is the only way to get sound, I'll be mute for a while. That's *way over my head* duncang.

I have sound coming from XMMS or Kcd (though I don't use the latter), but no sound like when I open and close programs. I would really like to have sound coming from the output jack instead of the mic jack, for maybe it would be as good as sound in XP, or better. However, I ain't about to recompile my kernel at this point. Don't want to fry my chicken, dude!
 
Old 07-06-2003, 07:31 AM   #14
duncang
LQ Newbie
 
Registered: Jul 2003
Posts: 9

Rep: Reputation: 0
AD1980 Driver Installation Instructions

This assumes you are using Red Hat Linux 9. If not then you may have to
compile the alsa drivers, lib and utils yourself. Make sure you install the
necessary compilers and kernel source files. See your distributions manuals for
instructions on how to do this - for some it might be easier to get Red Hat 9.

1. Download and install the latest ALSA drivers. I got them from
http://freshrpms.net.
alsa-driver-0.9.4-fr2.i386.rpm
kernel-module-alsa-0.9.4-fr2_2.4.20_18.9.i686.rpm
alsa-lib-0.9.4-fr1.i386.rpm
alsa-utils-0.9.4-fr1.i386.rpm
alsaplayer-0.99.75-fr1.i386.rpm

You must login as root to install. I installed using

rpm -i --force xxx

to force replacement of any existing files

2. Remove any other drivers from /etc/modules.conf. I just commented out the
following line and other associated entries

#alias sound-slot-0 i810_audio

But this line seems to get back in each time I restart - presumably the
hardware is automatically detected and the driver loaded ! Not sure how
to disable permanently but will try renaming the i810_audio.o file.

3. Now add the following to the modules.conf
BEGIN
# alsa
alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-intel8x0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

# restore mixer settings from /etc/asound.state
post-install snd-intel8x0 /usr/sbin/alsactl restore
# Save mixer settings to /etc/asound.state
pre-remove snd-intel8x0 /usr/sbin/alsactl store

# prevent syslog messages
alias snd-card-1 off
alias sound-service-1-0 off
alias sound-service-1-1 off
alias sound-service-1-3 off
alias sound-service-1-8 off
alias sound-service-1-12 off
alias snd-card-2 off
alias sound-service-2-0 off
alias sound-service-2-1 off
alias sound-service-2-3 off
alias sound-service-2-8 off
alias sound-service-2-12 off
alias snd-card-3 off
alias sound-service-3-0 off
alias sound-service-3-1 off
alias sound-service-3-3 off
alias sound-service-3-8 off
alias sound-service-3-12 off
END

4. Now try stopping and starting the /etc/init.d/alsasound daemon using the
the following command

/etc/init.d/alsasound stop

You should get output something like this:
BEGIN
[duncan@dunxpc duncan]$ su root
Password:
bash-2.05b# /etc/init.d/alsasound stop
Shutting down sound driver: done
bash-2.05b#
END

/etc/init.d/alsasound start

BEGIN
bash-2.05b# /etc/init.d/alsasound start
Starting sound driver: snd-intel8x0 done
bash-2.05b#
END

5. Now run alsamixer as root
BEGIN
┌───────────────────[AlsaMixer v1.00 (Press Escape to quit)]───────────────────┐
│ Card: Intel 82801BA-ICH2 │
│ Chip: Analog Devices AD1980 │
│ Item: Master │
│ │
│ ------ │
│ ┌──┐ ┌MM┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │ │ │ │ │ │ │ │ │ │ │ │ │ │ │ │ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │##│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 84<>84 84<>84 84<>84 84<>84 84<>84 87<>87 84<>84 84<>84 │
│ < Master >Master M Headphon PCM Surround Center LFE Line │
│ │
└──────────────────────────────────────────────────────────────────────────────┘
END

Modify settings to look like above. Make sure there is no 'MM' at the top
of the columns as shown in the second columns - this means MUTED and we
don't want that. Press M to toggle it on or off. Press escape to quit,
these setting are saved somewhere - not sure where yet.

6. Now go to Preferences -> Sound (and I am using Red Hat 9 here) and make
sure the sound server is started and sound is enabled for events

Things should be working fine now

Let me know where you get stuck
 
Old 07-06-2003, 10:05 AM   #15
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Rep: Reputation: 128Reputation: 128
duncang,

Thanks for the detailed instructions. I am using RedHat 9 (2.4.20-8). My mobo is Asus P4PE.

I'm using Windoze at the moment, because I gotta have Photoshop and PageMaker to finish a newsletter. Soon as I can I'll boot back into my wonderful Linux hdd and follow your directions. Will let you know the results.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't hear any sound when I play a cd or mp3...but tested with system tools->Sound Niceman2005 Linux - General 6 10-31-2005 10:51 AM
can't hear cd sound hartigan Linux - Hardware 4 08-22-2005 11:51 PM
Sound Card - can hear sounds and test fine - no cd sound PAB Linux - Hardware 11 10-27-2004 07:23 AM
sound card configured. can hear testsound. cant hear cd's tdr_nj Red Hat 2 04-19-2004 10:36 PM
Cannot hear CD sound kaboodle Linux - Newbie 1 11-01-2003 02:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration