LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-29-2004, 02:17 PM   #1
pingswept
Member
 
Registered: May 2003
Location: Cambridge, MA
Distribution: SuSE, RedHat, and OpenBSD
Posts: 116

Rep: Reputation: 15
Can't print from RH9/Ximian with CUPS to HP Laserjet 8000N


Hello penguin enthusiasts,

I'm trying to get my computer to print to a HP Laserjet 8000N on my local network. I can see cupsd running in the process list. I can set up a printer in Nautilus, and OpenOffice will start to print to the correct printer. The document shows up in the print queue under Nautilus, but the listed state just toggles back and forth between "pending: none" and "printing: job-printing." It stays in the queue until I cancel the job.

From the choices in Nautilus, it looks like I should be using the foomatic + hpijs printer drivers to print.

Any ideas on how to troubleshoot this? How would I check that the drivers are actually installed and working?
 
Old 06-29-2004, 02:40 PM   #2
SheldonPlankton
Member
 
Registered: Jun 2004
Posts: 129

Rep: Reputation: 15
You could always take a look at you cups log files in /var/log/cups
 
Old 06-29-2004, 02:53 PM   #3
pingswept
Member
 
Registered: May 2003
Location: Cambridge, MA
Distribution: SuSE, RedHat, and OpenBSD
Posts: 116

Original Poster
Rep: Reputation: 15
I set the LogLevel for cupsd to debug, and this showed up in my logs:

D [29/Jun/2004:15:48:00 -0400] [Job 3] 0 %%EndPageSetup
D [29/Jun/2004:15:48:00 -0400] [Job 3] 0 %%PageTrailer
D [29/Jun/2004:15:48:00 -0400] [Job 3] 0 %%Page: 2 2
D [29/Jun/2004:15:48:00 -0400] [Job 3] pw = 612.0, pl = 792.0
D [29/Jun/2004:15:48:00 -0400] [Job 3] PageLeft = 0.0, PageRight = 612.0
D [29/Jun/2004:15:48:00 -0400] [Job 3] PageTop = 792.0, PageBottom = 0.0
D [29/Jun/2004:15:48:00 -0400] [Job 3] PageWidth = 612.0, PageLength = 792.0
D [29/Jun/2004:15:48:00 -0400] [Job 3] 0 %%PageBoundingBox: 0 0 612 792
D [29/Jun/2004:15:48:00 -0400] [Job 3] 0 %%BeginPageSetup
D [29/Jun/2004:15:48:00 -0400] [Job 3] 0 %%EndPageSetup
D [29/Jun/2004:15:48:00 -0400] [Job 3] /usr/lib/cups/filter/cupsomatic: inserted option PS code:
D [29/Jun/2004:15:48:00 -0400] [Job 3] PJL: ^[%-12345X@PJL
D [29/Jun/2004:15:48:00 -0400] [Job 3] <job data>
D [29/Jun/2004:15:48:00 -0400] [Job 3] ^[%-12345X@PJL RESET
D [29/Jun/2004:15:48:00 -0400] [Job 3] gs PID pid2=16435
D [29/Jun/2004:15:48:00 -0400] [Job 3] gs command: gs -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjs$D [29/Jun/2004:15:48:00 -0400] AcceptClient() 11 from localhost:631.
D [29/Jun/2004:15:48:00 -0400] ReadClient() 11 POST / HTTP/1.1
D [29/Jun/2004:15:48:00 -0400] ProcessIPPRequest: 11 status_code=0
D [29/Jun/2004:15:48:00 -0400] AcceptClient() 12 from localhost:631.
D [29/Jun/2004:15:48:00 -0400] CloseClient() 11
D [29/Jun/2004:15:48:00 -0400] ReadClient() 12 POST / HTTP/1.1
D [29/Jun/2004:15:48:00 -0400] ProcessIPPRequest: 12 status_code=0
D [29/Jun/2004:15:48:00 -0400] ReadClient() 8 POST / HTTP/1.1
D [29/Jun/2004:15:48:00 -0400] ProcessIPPRequest: 8 status_code=0
D [29/Jun/2004:15:48:00 -0400] CloseClient() 12
D [29/Jun/2004:15:48:00 -0400] [Job 3] /usr/lib/cups/backend/192.168.1.31: No such file or directory
E [29/Jun/2004:15:48:00 -0400] PID 16433 stopped with status 22!
D [29/Jun/2004:15:48:00 -0400] [Job 3] foomatic-gswrapper: gs '-dBATCH' '-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDE$D [29/Jun/2004:15:48:00 -0400] ReadClient() 9 POST / HTTP/1.1
D [29/Jun/2004:15:48:00 -0400] ProcessIPPRequest: 9 status_code=0


Looks like I'm missing something in /usr/lib/cups/backend/192.168.1.31. What do I do about this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS not printing (HP LaserJet 5P) killerbob Slackware 6 06-04-2005 09:02 AM
HP LaserJet Series CUPS v.1.1 - Jobs never print Sloppyunderfoot Red Hat 1 04-29-2005 01:46 AM
can't get my HP LaserJet 6L to install/print ./usr/stevo Fedora 10 03-30-2005 11:03 AM
HP Laserjet 5p with Mandrake 10 does not print florencecm Linux - Hardware 3 02-24-2005 03:11 PM
HP LaserJet 6L + RH 7.2 = unable to print Lanny Linux - Hardware 0 05-06-2002 09:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration