LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-02-2003, 11:49 AM   #1
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Can't Locate Sound Modules


Every day I get these dam messages repeated over and over again in my log file:

Mar 2 11:21:01 domain modprobe: modprobe: Can't locate module sound-service-1-0
Mar 2 11:21:01 domain modprobe: modprobe: Can't locate module sound-slot-1

I'm running Linux on a laptop so I'm not surprised its having trouble. All the sound works fine though so thats not the problem.

Can I just give it what it wants and load these modules? If so where do I find them? This should probably go under the newbie forum because I don't know much about getting and installing modules.

<UPDATE>
Doing a little snooping around I found this directory:

/lib/modules/2.4.18-18.8.0/kernel/drivers/sound

In it there is a file called sound.o . Is this what I'm looking for?
</UPDATE>

Last edited by Crashed_Again; 03-02-2003 at 11:56 AM.
 
Old 03-02-2003, 12:48 PM   #2
arnold
Member
 
Registered: Dec 2002
Posts: 226

Rep: Reputation: 30
try
man modules.conf
 
Old 03-02-2003, 01:23 PM   #3
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Original Poster
Rep: Reputation: 57
Okay I did:

man modules.conf

It works very well. Now what? What am I looking for in the man pages? How do I identify the modules that are being requested in my log files?
 
Old 03-02-2003, 04:57 PM   #4
arnold
Member
 
Registered: Dec 2002
Posts: 226

Rep: Reputation: 30
My man says ..modprobe.. can be modified by the (optional) configuration file /etc/modules.conf
Check if there is a sound(snd) entry in modules.conf - comment it out and reboot
also look in /etc/modules
 
Old 03-02-2003, 05:19 PM   #5
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Original Poster
Rep: Reputation: 57
I thought it wasn't necessary to reboot to install modules? I'm confused. Can you read over my original post and tell me how I can find these EXACT modules being reported in the log files.

Thank you.
 
Old 03-02-2003, 05:39 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
It's not. You can remove and add modules without rebooting. rmmod and modproble are usually the ones I use to that.

Those are more than likely entries in your /etc/modules.conf file. You can comment them out (#) so that the error will go away. Post up your modules.conf file if you need help determining what to comment.

Cool
 
Old 03-02-2003, 05:56 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Gidday ...

my educated guess is that you're probably
trying to load modules for something that's
compiled into your kernel (since you said
sound is working fine) and thus no modules
to load present ...

My solution would be to edit the file that
RH uses to load modules, and remove the
offending lines ;)

Cheers,
Tink
 
Old 03-02-2003, 06:10 PM   #8
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Original Poster
Rep: Reputation: 57
Here is /etc/modules.conf

alias parport_lowlevel parport_pc
alias eth0 eepro100
alias usb-controller usb-uhci
options ide-cd dma=1
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
 
Old 03-02-2003, 06:20 PM   #9
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Hmm :)

I'm not using "little red riding hood"
for my daily work, it's been ages since
I had my hands on, and the only box with
it I have access to is running 6.2 :}

But I am fairly certain that RH 8 uses
more than just one config file to actually
pull up the modules system ...

In the old version there's
Code:
-rw-r--r--    1 root     root          261 May 15  2002 modules
-rw-r--r--    1 root     root           96 May 16  2002 modules.conf
-rw-r--r--    1 root     root         3492 Mar 14  2002 modules.devfs
in /etc
and
Code:
-rwxr-xr-x    1 root     root          483 Mar 16  2002 rc.modules
in /etc/rc.d

Use the force, Luke!
Errrh, I mean the grep! :}

Cheers,
Tink
 
Old 03-02-2003, 06:31 PM   #10
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Original Poster
Rep: Reputation: 57
grep sound /etc/*

returns the modules.conf and other files that contain the string 'sound' but they are not module related files.
 
Old 03-02-2003, 06:40 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
What if you try
Code:
grep -r sound-service /etc/*
?

Cheers,
Tink
 
Old 03-02-2003, 06:43 PM   #12
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Original Poster
Rep: Reputation: 57
It takes a while but it returns nothing.
 
Old 03-02-2003, 06:51 PM   #13
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
*sigh*

Sorry mate, you're alone now :)
I always disliked the big distros with Sys V scripts ;)

As for your <UPDATE> ... I don't think it is...
But you certainly know that's a binary.

Cheers,
Tink
 
Old 03-02-2003, 07:07 PM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Hmmm....

You could try looking at what point the error pops up. Then, go into your init scripts and find the area that most closely matches that string of startups. Then, look for what file it's calling on to probe your sound module, locate that file, comment out the line, and reboot to see if it worked (rebooting is just to see if the error comes up during bootup, not because you need to in order to remove/add the module).

Cool
 
Old 03-02-2003, 07:32 PM   #15
arnold
Member
 
Registered: Dec 2002
Posts: 226

Rep: Reputation: 30
i said boot because it is the booting process that is attempting to install the modules. The boot is driven from inittab which should have an entry si::sysinit:/etc/rc.d/rc.sysinit - run at boot time.
long story short - modprobe is run from startup scripts, uses modules.conf.

I may be wrong that modules.conf is the cause - only rebooting will tell for sure.

PS your modprobe messages in the log are harmless
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot locate modules.conf lowpingnoob Linux - Newbie 20 06-15-2005 09:04 PM
Can't locate module sound-service-1-0 jeffreybluml Linux - Newbie 1 12-09-2004 11:41 AM
unable to locate modules. cambie Red Hat 2 11-25-2004 12:08 PM
Can't locate modules /dev/modprobe hamish Linux - Software 2 04-09-2004 03:57 PM
my new kernel can't locate the sound card coldy Debian 5 11-23-2003 11:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration