LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-21-2010, 03:06 PM   #1
odocoileus
LQ Newbie
 
Registered: May 2008
Posts: 15

Rep: Reputation: 1
buzzing sound from speakers ONLY when no sound is playing ubuntu kk


This problem presented itself upon upgrading to ubuntu 9.10.
Any time something affects the sound system the buzz goes away. If a song plays, no buzz. If I simply adjust or mute the volume, no buzz. But after 10 seconds of no sound related activity, the buzz returns. This is a very loud and aggravating buzz, most likely made worse by the fact that I run my sound through an amplifier.

This feels like something I should have been able to easily find an answer for, but my search terms must be whack because I can't figure it out.

Thanks
 
Old 02-22-2010, 08:42 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi odocoileus, Welcome to LQ. Take a look at your mixer and see if your mic boost is turned up.

Good luck. ;-)
 
Old 02-22-2010, 10:23 PM   #3
odocoileus
LQ Newbie
 
Registered: May 2008
Posts: 15

Original Poster
Rep: Reputation: 1
I finally found it!

in /etc/modprobe.d/alsa-base.conf

there is this line:

Code:
# Power down HDA controllers after 10 idle seconds
options snd-hda-intel power_save=10 power_save_controller=N
Changing the 10 to a zero and rebooting fixed my problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer says it's playing the sound but nothing from speakers? lugoteehalt Linux - Software 2 01-11-2009 06:51 AM
Strange buzzing/static sound beanzapper Ubuntu 1 10-14-2007 07:56 AM
buzzing/distorted sound with creative sb live sound card Valkyrie_of_valhalla Linux - Software 1 06-07-2007 09:51 PM
ANNOYING buzzing sound 2uantuM Linux - Hardware 3 04-24-2004 03:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration