LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Box locks hard when exiting X (https://www.linuxquestions.org/questions/linux-general-1/box-locks-hard-when-exiting-x-164256/)

MalcolmV8 03-30-2004 02:46 PM

Box locks hard when exiting X
 
Hey,

I did a Mandrake 10 install on a new box. When I exit out of X the box will instantly lock hard with garbage on the screen and I have to cycle the power.

This only happens sometimes when exiting out of KDE but blackbox, for example, will do it everytime. All I do is try and exit the session and LOCK.

I have a Chaintech video card with an nVidia mx440 chipset. I tried downloading nVidia's official driver from their site and it did not fix the problem.

Anyone know what to look at in hopes of fixing it?

Thanks
Malcolm

waster 03-30-2004 03:08 PM

No idea what the issue is here, but I've had a similar problem. Firstly, is it really a hard lock? I thought mine had, too, including a keyboard freeze, but I was still able to ssh into the box over ethernet. This could provide valuable diagnostic information, as can the system logs: have you checked them?

I don't know how much you know, but do you know about using ctrl-alt-fn1 to fn6 virtual terminals? Can these get you out of the lock up? Also, when I had the same issue, switching from the X terminal to the virtual consoles caused screen corruption, but not a lock up. using ctrl-alt-f7 took me back to an uncorupted x display.

hope that gives you some leads.

waster

MalcolmV8 03-31-2004 09:48 AM

Thanks for the reply. Yes it's a hard lock. You can't even ping the box after it locks. Ctrl-alt-bakspc ctrl-alt-f1 etc. do nothing.

I have another video card on order since I'm really not sure where to go. I also plan on loading Mandrake 9.2 on a spare drive and see if it does it too. The memory and CPU was taken out of a known working good box but my MB and video card are new. Since the lock is related to logging out of the GUI I'm assuming video?

waster 04-02-2004 12:51 PM

my guess would be that the driver has bugs, or it is not xfree86 4.3 compatible (i think mandrake 10 comes with that). have you tried Knoppix on it?


All times are GMT -5. The time now is 11:02 PM.