LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   booting vmlinuz/initrd from a bootloader (https://www.linuxquestions.org/questions/linux-general-1/booting-vmlinuz-initrd-from-a-bootloader-166873/)

bob_man_uk 04-06-2004 11:36 AM

booting vmlinuz/initrd from a bootloader
 
Im not sure how to go about doing this, I have tried to use syslinux and loadlin but they both keep cumming up unable to fint "ROOT=" device regardless of what I tell it the root device is, so I there a bootloader that can do this job without asking too many questions or falling over at evert step, Im trying to boot thinstation but im hounded by errors

please help

Thanks in advance

Matty G

AutOPSY 04-06-2004 12:13 PM

What do you have a bootable CD or are you only using loadlin ?

Remember, to mount a root partition you must have one, if you havent installed Linux on this computer, or made any root partitions you will never mount the root partition except for maybe a floppy, or an initrd in memory from a CD boot.

bob_man_uk 04-07-2004 03:18 AM

no its not a cd boot Im trying to boot off of a hard drive ive been told that lilo can do the job i need, I have tried to use loadlin/linload whatever its name, but keeps stopping on "kernel panic" and states that there is no root device "root=" its telling me that there is no such root device even though I have configured the config file to have the root as as a hDD device ie /dev/hda1, how would I configure LILO to do this job? and is the initrd required to boot the OS.

ekman 04-07-2004 04:09 PM

Hi,
You can use GRUB, example menu.lst;
title Linux ramdisk
kernel (hd0,0)/bzImage root=/dev/ram ramdisk_size=16384
initrd (hd0,0)/ramdisk.img.gz

Double-check that you have support for ram-disk and initrd in the kernel.
Regards,
L Ekman

MS3FGX 04-07-2004 10:47 PM

SYSLINUX can only boot Linux from a FAT partition, so if you have "ROOT=/dev/hda1" that isn't going to work because Linux can't mount a FAT volume as root.

I have found that SYSLINUX works flawlessly for me, so something must be wrong in either your setup, or what you are trying to do.

Post your SYSLINUX.CFG file.


All times are GMT -5. The time now is 11:18 PM.