-   Linux - General (
-   -   Booting Problem (

Jiraiya 01-25-2006 02:07 PM

Booting Problem
I have two hard drives one is made by western digital and the other is made by seagate. My western digital is a 80GB IDE and my seagate is 250GB Serial ATA 150.I have my western digital HD set up as my Primary slave and my seagate as my fourth master. On my western digital hd I have SUSE installed and on my seagate hd I have FreeBSD 5.4-RELEASE installed.

In the past months i've been trying other distrobution just to see if there are other distro that I would like better than SUSE but in the end I like suse the best.

Before re-installing SUSE 9.3, I did a fresh install on my BSD hard drive and upgraded it to 6.0-RELEASE. When I installed BSD i didn't install any boot manager. FreeBSD 6.0-RELEASE installation went smoothly.

So now I go and install SUSE 9.3 and edited my grub menu so FreeBSD can boot from grub. Install SUSE and everything went smoothly.

My desktop rebooted and while it was going through POST check I took out the SUSE 9.3 disc. After I did this I expected to get a menu that allow me to boot into either SUSE or FreeBSD but instead it rebooted straight into FreeBSD.

I thought something went wrong during SUSE 9.3 so i re-installed again and the same thing happened. So, then I tried booting from the SUSE disc. this time instead of my desktop booting straight into FreeBSD i got a menu that let's me choose to boot to either SUSE or FreeBSD.

So the main problem here is that I have to use the SUSE disc to boot to either SUSE or FreeBSD. If I don't have the disc on my dvd drive, it will just boot straight into FreeBSD. My SUSE 9.3 system works just fine, it's just that I can't boot into it without having to use the CD.

My boot sequence are as follow.

1 - CD-ROM

2. Hard Disk

Here my grub menu.


linux:/home/jiraiyai # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Sat Jan 21 07:07:53 EST 2006

color white/blue black/light-gray
timeout 8
gfxmenu (hd0,1)/boot/message

title SUSE 10.0
root (hd0,1)
kernel /boot/vmlinuz-2.6.15-Jiraiya root=/dev/hdb2 vga=0x317 selinux=0 resume=/dev/hdb1 splash=silent showopts
initrd /boot/initrd-2.6.15-Jiraiya

title FreeBSD 6.0
root (hd1,0,a)
kernel /boot/loader
Changing my boot sequence doesn't make a difference either. Anyone know what going on?

pixellany 01-26-2006 08:33 AM

I infer that GRUB was installed during the SUSE install.

What options did the SUSE installer give you as to where to put grub? It needs to be in the boot sector of the first drive (or on a floppy)

You can verify where grub is by doing raw dump of the first sector as follows:
dd if=/dev/hda bs=512 count=1 | hexdump -C >bootsect

This writes a file containing the contents of the first sector on hda. You can compare this to GRUB stage 1--found in /boot/grub (you'll need to read stage1 using hexdump also.)

I had an issue with Ubuntu that was similar--I re-installer and told it to put grub on a floppy. (Too lazy to go back an figure out what the issue was...;) )

saikee 01-26-2006 11:30 AM

I think pixellany may have got it right by susepecting your MBR isn't Suse's Grub. That will explain why you boot straight into FreeBSD. In other word you may have inadvertently put FreeBSD boot loader into the MBR. The other possible explanation is the MBR has gone to the 250 Disk without you knowing the disk order has been swapped.

The test of the pudding is in the eating so boot back Suse and install its boot loader into the MBR again by

grub-install /dev/hdb
To test the disk order if (hd0)=hdb you can invokde a Grub shell and use the geometry statement to see the which one is hd0

geometry (hd0)
geometry (hd1)

All times are GMT -5. The time now is 01:40 PM.