-   Linux - General (
-   -   booting issue (addressed to linux experts) (

cmandan 09-25-2003 08:44 PM

booting issue (addressed to linux experts)
hello Linux Experts:

My boot-up process hangs with just "GRUB" on the screen. I reinstalled the boot-loader from the 9.0 CD but with the same result. Now, when i go in with the rescue cd, i notice that I cannot execute any command that is there inside /bin directory.It gives me a segmentation fault. The commands in /sbin dir work fine though.

#Segmentation fault

#segmentation fault

but ls will give me the directory listing.

I think, this is the cause of my bootup halt. During the boot-procedure, it tries to mount a few directories like /proc and others. But mount command does not work and so boot-up does not work either. How to get these commands to work?

I would appreciate your inputs here.


KevinJ 09-25-2003 10:22 PM

When you boot to the CD does it find your root partition and mount it on /mnt/sysimage?

If so, then "chroot /mnt/sysimage".

Then you should be able to do something like:

grub-install '(hd0)'

Once that is done, try "exit" and then "reboot".


cmandan 09-26-2003 11:51 AM

when i do grub-install '(hd0)' I get
/dev/hd1 does not have any corresponding bios drive

Please help.....very urgent...

KevinJ 09-29-2003 03:49 PM

I have had that too.. I fixed it, but I did two things and I am not sure which one fixed it. Maybe both.

1. Update GRUB package to the latest you can find. Compile from source if you have to.

2. in the "" file in your grub directory, make sure you have entries for both (hd0) and any partitions you are using in grub.conf, like (hd0,0) and so on and so forth.

Post the contents of grub.conf and if you have trouble.
What distribution of Linux?


All times are GMT -5. The time now is 04:47 AM.