-   Linux - General (
-   -   Booting Debian ISO with grub2 and a separate Kernel (

deepclutch 05-21-2010 06:51 AM

Booting Debian ISO with grub2 and a separate Kernel
Hello ,
I am trying to install Debian using debian netinstall cd(~160mb) with debian-installer.the cd boots into tmpfs.

it cannot mount My ext4 errs out:

mount:mounting /dev/sdb7  on /debiancd failed: No such device
I cannot see ext3/ext4 modules in kernel modules contains only isofs and fat modules.Is this the Problem?
All I Know ,the ISO is Mounted as tmpfs(ram).So ,If I am trying to Mount /dev/sdb7 ,It errors Out because,there is no space at all in RAM to mount!
So ,How do I mount My Partition containing ISO to Continue Installation(the Installer asks for the ISO)
I want to try booting ISO with Another Kernel outside vmlinuz,initrd.gz extracted from a working installation and make grub2 to use this kernel to boot as well as continue the ISO loop mounted, to Boot.
Currently,below is the menuentry on grub2:

menuentry "Debian ISO on /dev/sdb7" {
insmod ext2
set root=(hd0,7)
loopback loop /debian-testing-amd64-netinst.iso
linux (loop)/install.amd/vmlinuz boot=install.amd iso-scan/filename=/debian-testing-amd64-netinst.iso noeject noprompt --
initrd (loop)/install.amd/initrd.gz

^^^^ How Can I make Another Kernel to Boot For this Debian ISO?

Thank You

craigevil 05-21-2010 07:14 AM

Use the kmuto installer, ext4 needs a newer kernel that the one in the normal Debian installer.

Backported d-i images -

deepclutch 05-21-2010 09:58 AM

Thank You @craigevil.Will Try and report back :)

BTW ,I remember it is possible to boot another Kernel provided along with debian iso loop mounted to continue the installation. :| I forgot ,there is a "hd-media" kind of page in Debian ftp which can be used for this.Any Leads?

deepclutch 05-22-2010 01:48 AM

I was already trying daily built debian netinstall iso.I hope it already supports all these fs formats.
I tried lenny from "kmuto".it also not working for My Purpose.
What I want is to boot from debian iso using grub2(of ubuntu installation) and I succeed in booting the iso and it triggers Debian Installer which Directly Asks for debian "CD".and it asks to try to locate again and again on the cdrom device file /dev/hda.

Earlier ,with Ubuntu Alternate CD ,I can symbolically link CD Device(/dev/sr0) to the debian ISO(the very same iso I am booting from! using Grub2) mounted from the partition where it is(/dev/sdb7).

But ,with Debian ISO ,I can't Figure anything.As I know ,it is copied to RAM(tmpfs) and if anyway I can copy the debian-netinst.iso to ramdisk(I've got 2 GB RAM) and link it to /dev/hda ,The Installation can Continue.For that ,I need to single out debian iso from the partition /dev/sdb7 and copy to /dev/ram0 or something similar.
Help is needed,
Thank You :)

deepclutch 05-23-2010 06:30 AM

While I wanted to install debian latest daily snapshot iso the same way ,that I learned debian iso when booted does not load all file system support.debian-installer has to loop mount the debian-iso so that to pull out the udeb's which contains the modules needed.
So,the way Ubuntu Alternate CD ISO is booted will not work with Debian testing ISO.
Here is How:

Installed Debian testing using debian-testing-amd64-netinst.iso daily built snapshot on to a ext4 partition.
Here is How I installed from CD ISO:
1) download vmlinuz and initrd.gz for hard disk boot provided by Debian team here:
For Mine ,64-bit OS ,I downloaded from amd64 folder:
I downloaded the "capable"(supports more filesystems,specifically for hard disk iso booting) Linux and initrd.gz to /dev/sdb7 /debian folder,Where "debian-testing-amd64-netinst.iso" iso also resides.

2)I'm having Ubuntu 10.04 Lucid already on another partition with Grub2 Bootloader.
I added below entry to boot the debian iso from grub2(for booting iso which is in "debian" folder on /dev/sdb7):

menuentry "Debian ISO on /dev/sdb7" {
insmod ext2
set root=(hd0,7)
loopback loop /debian/debian-testing-amd64-netinst.iso
linux  /debian/vmlinuz boot=/debian iso-scan/filename=/debian/debian-testing-amd64-netinst.iso noeject noprompt INSTALL_MEDIA_DEV=/dev/sdb7
initrd /debian/initrd.gz

^I don't think "INSTALL_MEDIA_DEV=/dev/sdb7" has any effect on debian-installer searching for debian ISO.But ,that's how I booted with ISO.

3) When Debian ISO Boots, It starts debian-installer(it's also a command,once booted) with ncurses based User Interface.
the installer offers to search for debian compatible isos on different hard disk partitions.It cannot search on ext4 partitions(that's what I experienced).
Knowing this ,I copied debian-testing-amd64-netinst.iso to a ext3 partition at /dev/sdb8 .
Installer searched and mounted debian-testing-amd64-netinst.iso as a loop device /dev/loop1
and install proceeds as usual.I ended up with a network enabled system also grub2 installed from the Debian.
PS:I don't know ,but when I tried loop mount or even mount ext3,ext4 partition it never worked with debian netinst cd iso!when boots it supports only a couple of file system formats like isofs,vfat(fat32).. .no ext3 also.I think ,later on ,debian-udebs(kernel modules are stored as *.udeb) containing the necessary modules has to be extracted and installed,thus ext3 and ext4 supported!

This will yield a basic Debian System with network support.

Thank You :)

^This is a Copy of My Original Post

All times are GMT -5. The time now is 12:41 PM.