Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 01-25-2006, 01:16 PM   #1
LQ Newbie
Registered: Jan 2006
Posts: 7

Rep: Reputation: 0
Boot problems in Debian (Etch)

I'm having a problem (I think kernel related) booting my system:

When I try to boot into my system I get an error when mounting my root partition that the last write and mount times are in the future. I am prompted to run fsck manually and date gives me a time 3 hours in the past... I think this might be a cpu frequency scaling issue or something but I'm not sure and I haven't come across any possibilities yet. Running fsck and setting the mount and write times back 3 hours allows me to boot but this is obviously not a nice solution. This only happens if the machine is rebooted within 3 hours of the last boot of course.

Some statistics:

Debian Etch
Dell Inspiron 600m
Kernel 2.6.12
Root partition is ex3
Old 01-25-2006, 01:54 PM   #2
Senior Member
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian
Posts: 2,192

Rep: Reputation: 339Reputation: 339Reputation: 339Reputation: 339
This probably just means your clock/timezone is set wrong. Nothing more sinister than that. Lot's of info on how to manage this on the web. I just went to Google and searched variations of these words: "linux date clock time wrong incorrect". Came up with the following hits (amongst many others):

On your system, also run "man date" and "man hwclock" for additional info.
Old 01-25-2006, 01:56 PM   #3
Registered: Feb 2003
Location: Oklahoma
Distribution: Debian Unstable
Posts: 244

Rep: Reputation: 30
I know this seems like a lame answer but if you shut down the computer over night the problem will be gone.
Old 01-25-2006, 02:08 PM   #4
LQ Newbie
Registered: Jan 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I can't see any problems with my clock settings, they are on the correct time and timezone. However, before the system clock is set to the hardware clock's time during boot is when I get this error.
Old 01-25-2006, 02:18 PM   #5
Registered: Aug 2004
Location: Philly
Distribution: Debian Lenny, FreeBSD
Posts: 577

Rep: Reputation: 30
When I had this problem it was because of one thing.
My computer needed a new battery (CR2032). Once it was replaced I had to run fsck once again and all has been well since.
Old 01-25-2006, 02:22 PM   #6
LQ Newbie
Registered: Jan 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Would there be any lag in the hardware clock if the battery were dying? I haven't been paying too close attention to it but every time I check either with hwclock or in bios before booting it looks correct.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Etch. Theoretic Debian 14 08-08-2006 06:00 PM
USB camera Debian Etch chestnut1969 Debian 4 01-10-2006 02:44 PM
Error message during boot Debian Etch anti.corp Debian 3 12-14-2005 08:15 PM
Debian "etch" install problems - no NIC found SharkeyNor Debian 2 08-14-2005 04:12 AM
which one to d/l for debian etch? greythorne Debian 8 07-27-2005 02:25 AM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:59 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration