-   Linux - General (
-   -   boot Linux system on USB-stick (

graphit 04-20-2011 03:49 PM

boot Linux system on USB-stick
1 Attachment(s)
Hello everybody!

I have installed a Debian System on a removable USB-drive just the same way I would do it for a normal harddisk drive.
All was working fine until I tried to boot the system.

I have set up the USB-stick as first boot device in the BIOS, and written grub in the MBR of the stick.
When trying to boot it, "Grub Error 2" will always be risen (I am using grub-0.98).

The only drive I have installed except the USB-stick is a SATA-harddisk, so normally the USB-stick is called /dev/sdb.

I have already tried changing root in menu.lst to (hd0,0) or the kernel root to /dev/sda1 but nothing seems to help.

Thanks for answers!

gentisle 04-20-2011 07:50 PM

Did you remember to set the USB stick to an active partition w/fdisk? In the future, you might mention which Debian system since there are several Debian based distros not to mention Debian itself.

graphit 04-21-2011 01:11 AM

I have formated the USB-stick with an ext3 filesystem.
The system I installed was Debian5.

Thanks for answering!

gentisle 04-21-2011 11:12 AM

So is it working now? You didn't mention whether you had gone into fdisk and set that partition as active. Someone else might answer here, but maybe the installation program does that for you??? I haven't tried Debian 5.

graphit 04-22-2011 02:35 AM

I got it running by testing it on my friends computer. This computer seemed to have different device priorities, as the USB-stick was called hd0. But I still wonder why grub found its menu.lst file on his PC and not on mine.

Does grub remember from which partition it was written in the MBR by grub-install?

I finally got it working on my PC too, but only by using the grub instance installed on my harddisk.
The USB-stick turned out to be hd1.
Does it make a difference for the enumeration of drives, if you change their booting priorities? Could the changed priorities be the reason, that grub did not find its menu.lst file?

The main problem is solved now, but I am confused :rolleyes:

btw the partition on the USB-stick has got the bootable flag set if you meant this with active.

Thanks for your help!

All times are GMT -5. The time now is 01:33 AM.