-   Linux - General (
-   -   Bluetooth usb dongle problem (

rng 01-01-2013 11:36 PM

Bluetooth usb dongle problem
I am using a bluetooth usb dongle on Debian-Testing with systemd, bluez and blueman installed. When I connect the usb dongle, it does not automatically get connected. It does not do so even after following commands:

sudo /etc/init.d/bluetooth start

sudo systemctl enable bluetooth.service
sudo systemctl start bluetooth.service

It get connected properly (without any commands) on rebooting with bluetooth usb dongle attached. Is there any way I can use this dongle without rebooting the computer? Thanks for your help.

kareempharmacist 01-02-2013 01:56 AM

run the following command as root:

hidd --search

kareempharmacist 01-02-2013 02:01 AM

the command hidd is the command that will solve your problem if you put it in the right place during boot

rng 01-02-2013 04:55 AM

Apparently hidd command has been deprecated. I cannot find it on my system.

kareempharmacist 01-02-2013 05:06 AM

sorry i didn't know that..

kareempharmacist 01-02-2013 05:10 AM

the following command will be helpful after a reboot with the dongle attached

dmesg | grep bluetooth

rng 01-02-2013 05:45 AM

Following is the output on attaching usb dongle on running system:

$ dmesg | grep blue
[  230.387511] Bluetooth: Core ver 2.16
[  230.387540] Bluetooth: HCI device and connection manager initialized
[  230.387544] Bluetooth: HCI socket layer initialized
[  230.387547] Bluetooth: L2CAP socket layer initialized
[  230.387557] Bluetooth: SCO socket layer initialized
[  230.407885] Bluetooth: Generic Bluetooth USB driver ver 0.6
[  230.581060] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  230.581065] Bluetooth: BNEP filters: protocol multicast
[  230.589754] Bluetooth: RFCOMM TTY layer initialized
[  230.589766] Bluetooth: RFCOMM socket layer initialized
[  230.589770] Bluetooth: RFCOMM ver 1.11

And it is identical if the command is given after rebooting with dongle attached.

rng 01-02-2013 10:37 AM

I found that as soon as bluetooth usb dongle is inserted, "bluetoothd --udev" is started. I have to give command "killall bluetoothd" before issuing command: "sudo systemctl start bluetooth.service" for bluetooth to work properly. How can I prevent bluetoothd from starting automatically as soon as usb dongle is inserted?

kareempharmacist 01-02-2013 11:03 AM

install rcconf
run it as root

rng 01-02-2013 11:40 AM

rcconf does not help since "bluetooth --udev" is not starting at bootup but later as soon as usb dongle is plugged in.

rng 01-08-2013 11:10 PM

Now the bluetooth is working and I am able to receive files from mobile phone but cannot send files to it. The dialog box states "sending.." but it is not able to send and after about 30 seconds there is an error message dialog box stating that the file could not be sent. How can I troubleshoot this?

I have following packages related to bluetooth installed (output from wajig package manager):

Package                Installed      Previous        Now            State
bluedevil                  1.2.3-1                1.2.3-1                1.2.3-1                install
blueman                    1.23-1                1.23-1                1.23-1                install
bluetooth                  4.99-2                4.99-2                4.99-2                install
bluez                      4.99-2                4.99-2                4.99-2                install
bluez-cups                  4.99-2                4.99-2                4.99-2                install
bluez-gstreamer            4.99-2                4.99-2                4.99-2                install
gir1.2-gnomebluetooth-1.0        3.4.2-1                3.4.2-1                3.4.2-1                install
gnome-bluetooth            3.4.2-1                3.4.2-1                3.4.2-1                install
libgnome-bluetooth10        3.4.2-1                3.4.2-1                3.4.2-1                install
obex-data-server            0.4.5-1+b3            0.4.5-1+b3            0.4.5-1+b3            install

rng 01-30-2013 11:58 AM

I am getting following error:

Connection to bluez failed.

Bluez daemon is not running, blueman-manager cannot continue.
This probably means that there were no bluetooth adapters detected or bluetooth daemon was not started.

How should I proceed. Thanks for your help.

rng 04-15-2013 02:56 AM

I am still not able to solve this problem. I am running Debian wheezy and it is otherwise working very well except the bluetooth with usb dongle, for which I often have to boot into another distro on the same machine, where it works perfectly. Normally there is no error message but today I got this error message at bootup:

Failed to apply network settings:

org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

You might not be able to connect to the Bluetooth network via this machine

What does it mean and how can I solve this? Thanks for your help.

jACK-ah 04-17-2013 11:15 PM

sory dont know thats something unusall prb you are having

rng 04-20-2013 10:11 AM

There has been a change suddenly. Now when I attach the bluetooth dongle, nothing happens. The bluetooth icon does not appear on the system tray. I run 'sudo systemctl start bluetooth.service' and it finishes without any error. The command 'systemctl status bluetooth.service' shows that the service is active and running. But when I run blueman application, no device is seen. The dmesg command shows that the dongle is being detected:

[  96.827371] Bluetooth: Core ver 2.16
[  96.827403] NET: Registered protocol family 31
[  96.827408] Bluetooth: HCI device and connection manager initialized
[  96.827413] Bluetooth: HCI socket layer initialized
[  96.827417] Bluetooth: L2CAP socket layer initialized
[  96.827427] Bluetooth: SCO socket layer initialized
[  96.839737] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  96.839741] Bluetooth: BNEP filters: protocol multicast
[  96.884691] Bluetooth: RFCOMM TTY layer initialized
[  96.884701] Bluetooth: RFCOMM socket layer initialized
[  96.884705] Bluetooth: RFCOMM ver 1.11

I cannot understand whether the bluetooth dongle has gone bad or there is some software problem.

All times are GMT -5. The time now is 11:45 PM.